4 Replies Latest reply on May 7, 2018 5:40 AM by Deepak S

    CMDB Federation Retrieval Method - To view federated data

    Deepak S
      Share This:

      Hi Friends,

       

      Need your help on the Retrieval method of CMDB federation. I have followed the BMC documentation and created the fed as below:

        1. Created a Repository plugin on JDBC adapter to connect to a Oracle DB. Its successful and plugin is loaded.
        2. Using the Retrieval Definitions, I created a federated data class as shown below.
        3. Created a Federated Relationship class as below:

       

      Now I don’t know where I can see the federated data. I launched the Atrium Explorer, but could see only the CI and its relationships. Not sure where I can visualize the Federated data.

      I did not find any documentation on this one, also nothing in YouTube videos, and hardly anything on community.

       

      Thanks,

      Deepak

        • 1. Re: CMDB Federation Retrieval Method - To view federated data
          Jeremy Ashe

          I'm having the same issue. This is what I've tried so far based on this comment from the Atrium documentation:

           

          "Federated data is information about a configuration item (CI) that is stored outside BMC Atrium CMDB and is linked to CIs in BMC Atrium Configuration Management Database (BMC Atrium CMDB). BMC Atrium Explorer allows you to retrieve federated instances that are related to a core CI in the BMC Atrium CMDB."

           

          And also here, instructions to view federated data related to a CI (it sounds like this is what you are doing above):

          Viewing federated data in BMC Atrium Explorer - Documentation for BMC Atrium Core 9.1 - BMC Documentation

           

          I've created the federated data class (assets in a legacy Remedy database) and a federated relationship class to the BMC_Person CI Class using the username which is stored on both records. I found a person record that I know has a match in the legacy assets and dropped it into the Atrium Explorer but there are no child IDs found for me.

           

          I'm wondering if the federated data, which has a distinct namespace (BMC.Fed) is maybe also stored in a different dataset.

          1 of 1 people found this helpful
          • 2. Re: CMDB Federation Retrieval Method - To view federated data
            Deepak S

            Thanks Jeremy for the update.

            Looks like there was some issue in Atrium Explorer, however I can see the data in the Fedetared data class forms created.

            • 3. Re: CMDB Federation Retrieval Method - To view federated data
              Carey Walker

              Hi Deepak and Jeremy,

               

              I had pretty much the same issue about a year back. It required a hot fix from BMC to resolve. This fix was supposed to be included in 9.1.03 and above, so if you are already at tat version or above, it won't be the same issue.

               

              So I had done all the set up required correctly, I could see the federated class form and if I searched that form, it correctly populated the data from the federation source (in my case it was simply a test table we created in the ARSYSTEM DB). This proved that all the ODBC/JDBC config was correct and that the relationship from the federated class (the key attributes etc) were working. Except that in Atrium Explorer, when you double clicked (or select Expand Both) for the CI class that was supposed to have the related federation class, nothing happened!

               

              Original ticket number with support was 00103194.

               

              If you have a test area where you can be a bit reckless , please try the following.

               

              Find the CI you are federating FROM. I'll assume it's in BMC.ASSET and has been reconciled so has a valid recon. id (i.e. it is not 0).

               

              Set the reconid back to 0 (after saving it's value somewhere). Save the CI.

               

              Now go back to Atrium Explorer and try the double-click or expand both on the CI again. If you have the same issue, voila you will see the federated class related to the core CI and you will be able to use the functionality as expected (i.e. drill in to see attributes etc).

               

              Please let us know how this goes.

              • 4. Re: CMDB Federation Retrieval Method - To view federated data
                Deepak S

                Thanks Carey, I guess I have tried already making the recon Id = 0 and cheked but still I was not able to visualize the Fed data in Atrium Explorer

                 

                 

                Thanks,

                Deepak

                1 of 1 people found this helpful