3 Replies Latest reply on Apr 27, 2018 4:14 AM by Nitesh Kumar

    Using Deployment Management Console to move data

    Peter Lundqvist
      Share This:

      First off, I am really excited for this tool and I have been since I first saw it in 9.1!

      I can't wait to start using it for all our deployments

       

      I've never had any problem moving forms and workflow, but I keep running in to issues with data.

       

      Today I wanted to try to move a bunch of incident templates from dev, to test, and to production. The job was easy enough to create, build, and deploy.

      However, nothing happened. The log says nothing of interest (basically only the output from AR System Import Tool) but there was nothing happening in the workflow/SQL logs related to the template form.

       

      I increased the log level to TRACE for ARSYS.ARF.ARMIGRATE and looked in the plugin log, but it provided no help to me - everything related to the package. This was the only thin I found that related to the contents of the package.

      <PLUGINSVR> <TNAME: pool-29-thread-7         > <INFO > <ARPluginContext                                   > <                              ARPluginContext.java:173       > /* ti apr 24 2018 04:53:30.312 */  <ARSYS.ARF.ARMIGRATE>Success: Results from import log file:
      --------
      [ti apr 24 16:53:30.270] INFO  - AR System Import Tool 9.1 build002 ti apr 24 16:53:30.269
      [ti apr 24 16:53:30.270] INFO  - APITIMEOUT from system property : -null
      [ti apr 24 16:53:30.270] INFO  - APITIMEOUT from Environment : -null
      [ti apr 24 16:53:30.274] INFO  - Starting import of /app/bmc/ARSystem/db/BMC_DEPLOYMENT_PACKAGES/RDGAA5V0FOBM3APHOQA5PGSCE5SJXZ/_items/IDGAA5V0FOBM3APHOQA6PGSCE5SJYA/HPDTemplateSPGLookUp.arx
      [ti apr 24 16:53:30.276] INFO  - Found new form in file : HPD:TemplateSPGLookUp
      [ti apr 24 16:53:30.280] INFO  - Auto generating mapping information
      [ti apr 24 16:53:30.280] INFO  - Attempting import from source form HPD:TemplateSPGLookUp to destination form HPD:TemplateSPGLookUp on server real.server.name.here
      [ti apr 24 16:53:30.288] INFO  - Import Completed in 0,014 seconds. 1 records were imported to HPD:TemplateSPGLookUp. From File /app/bmc/ARSystem/db/BMC_DEPLOYMENT_PACKAGES/RDGAA5V0FOBM3APHOQA5PGSCE5SJXZ/_items/IDGAA5V0FOBM3APHOQA6PGSCE5SJYA/HPDTemplateSPGLookUp.arx
      
      
      <PLUGINSVR> <TNAME: pool-29-thread-7         > <INFO > <ARPluginContext                                   > <                              ARPluginContext.java:173       > /* ti apr 24 2018 04:53:30.314 */  <ARSYS.ARF.ARMIGRATE>Dispatch completed of FilterAPI call, opCode=8
      

       

      Which would indicate that everything worked, but the content (the template) I tried to import is not there. I checked the arx file and it looks ok.

       

      Any advice on troubleshooting this further?