3 Replies Latest reply on Mar 28, 2018 8:14 AM by Peter Lundqvist

    Unable to load pluggable provider User Details Pluggable Provider

    Peter Lundqvist
      Share This:

      Last week we tried to upgrade DWP to 18.02 (with RSSO, we have never used ASSO on this platform) from 3.4 in our development environment.

      The upgrade went fine according to the logs, but when we tried to log on we just got a spinning wheel.

       

      After enabling debug logs we see this in our ux.log:

      09:52:04.039 | localhost-startStop-1      
      | RID: none | DEBUG   | c.b.b.m.m.MultiTenantTransactionManager | Closing JPA EntityManager [org.eclipse.persistence.internal.jpa.EntityManagerImpl@59f71540] after transaction 09:52:04.040 | localhost-startStop-1      
      | RID: none | INFO
      | SYS-INFO | [Pluggable Provider Manager] Provider 'User Details Pluggable Provider' is enabled for tenant 000000000000001 09:52:05.708 | localhost-startStop-1      
      | RID: none | ERROR   | SYS-INFO | [Pluggable Provider Manager] Unable to load pluggable provider User Details Pluggable Provider for tenant 000000000000001 com.bmc.bsm.mobile.errorhandling.MobilityServerException: There was a problem processing the mobility server configuration. (MyIT Administration: Data Store CCS)     
      at com.bmc.bsm.mobile.config.ConfigurationManager.getConfigurationData(ConfigurationManager.java:218)     
      at com.bmc.bsm.mobile.config.ConfigurationManager.getConfigurationData(ConfigurationManager.java:193)     
      at com.bmc.bsm.mobile.config.ConfigurationManager.getConfigurationData(ConfigurationManager.java:263)     
      at com.bmc.bsm.mobile.config.CCSConfigurator.getCCSConfData(CCSConfigurator.java:110)
      
      

      Any idea on how to solve this?

      And also, the form MyIT Administration: Data Store CCS is not to be found on the AR Server the dev environment is connected to. The ux-patch (2.0) has been installed.