6 Replies Latest reply on Nov 8, 2017 11:48 PM by Udit Maheshwari

    Package installation got stuck at assigned state

    Udit Maheshwari

      Dear All,

       

      I have rolled out software installation package (size is of 100MB) on 300 devices and it was installed on approx 120 devices only. On rest of the devices, installation got stuck at assigned state from last 3 days.

       

      Kindly suggest.

       

      Thanks,

      Udit Maheshwari

        • 1. Re: Package installation got stuck at assigned state
          Udit Maheshwari

          Dear Steve Gibbs,

           

          Kindly suggest.

           

          Thanks,

          Udit Maheshwari

          • 3. Re: Package installation got stuck at assigned state
            Steve Gibbs

            Udit,

             

            You did not provide enough information to even take a guess at trying to resolve. Let me ask you several questions.

             

            • What did the devices that succeeded have in common?
              • All in same location or locations with higher bandwidth?
              • All using relays or directly connected to Master?
              • All desktops vs. laptops?
              • Use of Transfer Windows (bandwidth reduction/management)?
            • If some devices succeeded and others are still "waiting" are located at same site, are the still "assigned" ones laptops where they may have used another relay due to travel, WiFi vs. Ethernet, taken home.
            • Remember that by design BCM uses Relays to distribute packages and the package must complete download in the "Filestore" before it can begin to distribute to end point devices. If none of the devices "UNDER" a relay received the package then please check the Relay's Filestore to see if package there:
            • If there are no reasons why some succeeded and some are still waiting then on a device that you believe should have executed do these things:
              • Make sure the AV exclusion is in place on these devices (sometimes customers have "extra" antivirus solutions installed.
              • See if the package is on device or in a downloading state by going into the file folder for BMC Client Management, "C:\Program Files\BMC Software\Client Management\Client\data\OperationalRules\packages\" and see if package folder created and populated.
              • Look at the Op Rule log on the same device along with the MTXAGENT log and look for any errors. Since time has passed you may need to find the log that matches the same time frame.

            If none of these ideas provide any solution, you will need to contact support. First try to "Reassign Op Rule" on a device that has yet to complete and see if after 10 minutes the Filestore on the target is trying to download the file. Pick a device where it's Parent/Relay already has the package in it's Filestore.

             

            Best I can do to assist.

            • 4. Re: Package installation got stuck at assigned state
              Udit Maheshwari

              Hi Steve,

               

              Thanks for the update.

               

              • Please find below inputs:

                        All are in same location

                        All are using 1 relay

                        All are desktops

                        No use of transfer window

               

              • All are desktops,so no possibility of moving
              • Please find below screenshot from FileStore of the Relay device

               

              • No packages folder under Operationalrules.

               

              Thanks,

              Udit Maheshwari

              • 5. Re: Package installation got stuck at assigned state
                Steve Gibbs

                Seeing this screenshot on your relay would indicate that no device that was using this device as its parent could have ever gotten the package. Could the ones that succeeded actually used the master as its parent/relay because they got the package installed?

                 

                Are you sure your Relay has no AV running real time scanning still happening?

                 

                Try to Reassign the Op Rule to a device you know is reachable under this relay and watch the FileStore on the relay and see if that changes to downloaded...

                 

                You need to open a Support Ticket because you may have other issues with your configuration...  Can't really troubleshoot your situation using this process...

                 

                Good luck!

                • 6. Re: Package installation got stuck at assigned state
                  Udit Maheshwari

                  Hi Steve Gibbs,

                   

                  Thank you so much for the update.

                   

                  I have changed the relay for package deployment and now, its working for all devices.

                   

                  Thanks

                   

                  Udit Maheshwari