5 Replies Latest reply on Oct 6, 2017 6:41 AM by Bojan Vladisavljevic

    BMC Remedy chat doesn't work on every browser

    Bojan Vladisavljevic



      I need help with BMC Remedy chat.


      Environment description


      I've recently upgraded internal environment to latest version 9.1.03:

      a. Midtier 9.1.03 on Windows Server 2012

      b. ARS server on Linux Red Hat 7.2, with following components:

        1. ARS Server

        2. Atrium Core

        3. Atrium Integrator

        4. ITSM

        5. SRM

        6. SLM


      After that I was tasked to install chat feature. I followed instructions from the documentation and did the following:

      1. created user openfire in database with corresponding schema openfire

      2. installed Openfire server version 4.0.2 on midtier server. All default ports were left, and firewall on server is turned off.

      3. copied arauth.jar, ojdbc14.jar, arapi91_build002.jar and arutil91_build002.jar to <Openfire installation>\lib folder

      4. I started <Openfire installation>\bin\openfire.exe as administrator and server was up as it was supposed to

      5. On web location http://<midtier>:9090 I followed the wizard and set up the openfire server as recommended (language=English, server domain=test-rem-win, SQL connection=Default, Orcale DB credentials, Default and finally I skipped admin password settings)

      5a. I verified that wizard created tables in database with necessary values

      6. I've reaccessed web location http://<midtier>:9090 and accessed Server properties and changed the 'provider.auth.className' to "org.jivesoftware.openfire.auth.HybridAuthProvider"

      7. I've added following values to Server properties as well:

        a.  hybridAuthProvider.primaryProvider.className=org.jivesoftware.openfire.auth.DefaultAuthProvider

        b.  hybridAuthProvider.secondaryProvider.className=com.bmc.arsys.social.chat.openfire.auth.ARAuthProvider

        c.  arsProvider.password.<ar server>=<hashed value I found in ar.conf>

        d.  arsProvider.port.<ar server>=6000

      8. On 'Data Visualization Definition', on record where Definition Name=ChatConfig Simple Definition was updated to:

              # XMPP server name



              # Connect to XMPP server using HTTP. Possible values - true or false.



              # XMPP server port number usually it is 5222 if connection is not over HTTP. For HTTP/HTTPS connection, the default value is 7070/7443



              # Specify whether XMPP server supports TLS/SSL over the communication or HTTPS. If this property is set to false, all the communication will be in plain text format. Possible values - true or false.



              # Specify whether XMPP server has AR Authentication plugin installed. Possible values - true or false.



              # Specify whether to create chat user mapping automatically for AR users





      9. On 'System Configuration Settings – System Settings' form I've checked Enable chat checkbox.

      10. I restarted whole server where Midtier is hosted, ARS and started Openfire as admin user


      Actual issue


      After I logged in as one of the users chat started to connect and after a while just turned to red triangle with esclamation mark. When I do a mouseover I can see an error: "Failed to connect to chat server test-rem-win. Click to reconnect".

      I couldn't find any errors on Midtier or Openfire log that would point me to the issue. I can telnet server over port 5222. I installed Pidgin to test out the connection and issues and it connected and started working flawlessly. So I started changing browsers and browser versions and found that chat only works with:

      1. Firefox 55.0.3 or less
      2. Internet Explorer (latest)
      3. Edge (latest)

      It doesn't work with Chrome or Firefox 56 (latest) at all. I tried anything I could think of: to turn off my local firewall, disable firefox security, telnet through port 5222,... I even tried to record the Fiddler log, but it literary didn't record anything, even after I clicked reconnect, loading kept spinning, but there was no connection attempt.


      Did someone encounter this? Did you perhaps manage to solve it? Do you have any suggestions or do you require any additional details?





      Message was edited by: Bojan Vladisavljevic