3 Replies Latest reply on Sep 13, 2017 5:55 PM by Paul Robins

    85% RQC UTILIZATION DETECTED FOR MONITOR CONTROLO

    Pavel Grund

      Hello everyone,

       

      I have a question about RQC utilization in CONTROLO monitor. Sometimes, we have a problem with utilization in CONTROL-O in TEST region, especially with RQC.

      After typing command F CONTROLO,USAGESTATS we have got: (We use CONTROL-O 9.0.01.)

       

      CTO356I USAGESTATS                                                                

      CTO15EI RQC  USAGE: CURRENTLY   1%, HIGHEST 100% (000005 AND 020000 OUT OF 020000)

      CTO15EI PND  USAGE: CURRENTLY   0%, HIGHEST   6% (000000 AND 000004 OUT OF 000076)

      CTO15EI WSC  USAGE: CURRENTLY   0%, HIGHEST  10% (000000 AND 000007 OUT OF 000075)

      CTO357I COMMAND ENDED SUCCESSFULLY                                                

       

      We have got a 100% utillization. If I'am trying to find a solution in BMC Documentation, I will get these two different answer:

       

      INCONTROL INSTALATION GUIDE 9.0.01 - Customizing

      ------------------------------------------------------------------------

      If the RQC utilization exceeds 80%, increase the value of the

      RQC# parameter.

      The default value is 20000.

      For further details on the MODIFY USAGESTATS command, see the

      INCONTROL for z/OS Administrator Guide.

       

      If I'am looking for the answer in Administrator Guide, I will get this answer:

      -------------------------------------------------------------------------------------------

      Control-O users can tune the PND and WSC by adjusting the values of the WAITPR# and WSCs# parameters

      in the CTOPARM member. However, the RQC cannot be tuned. Look for any PTFs that correct problems

      handling RQC.

       

      I am sorry, but these two different recomendation seems to me confusing.

      I have been trying to find help in BMC support central and I have got this anwer:

       

      KnowledgeArticle - BMC

       

      Please, if anyone of you knows the right way which to go, please help me. We are in TEST region now, but this may happen in PRODUCTION as well.

       

      Thank you very much

       

      Regards

       

      Pavel

        • 1. Re: 85% RQC UTILIZATION DETECTED FOR MONITOR CONTROLO
          Irvan Prama

          Hello Pavel,

           

          as i know, i had that problem in 2015. You should reduce the number of rules running always in LOG mode, and change more rules from LOG to PROD. because a lots of rules in LOG mode may lead to a high RQC utilization.

          for solution, im increase the parameter and increase size an dataset, but my suggestion you can contact BMC first and open the ticket.

          because sometimes a same problem not always have same solution.

           

          Thank you.

          you may reduce the number of rules running always in LOG mode

          • 2. Re: 85% RQC UTILIZATION DETECTED FOR MONITOR CONTROLO
            Pavel Grund

            Hello Irvan,

             

            thank you for your reply. I have already chcecked out all of the rules, but all of them are in a PROD mode. This problem with RQC utilization has been always active when WTO buffer shortage or an unusual number of messages have been produced to MVS console.

             

            This may happen, if there is a new program in some JOB or have been made some changes in processing.

             

            Ok, I am probably going to open a ticket. Becouse, there is a mismatch in a documentation.

             

            Thank you for your suggestion.

             

            Best regards

             

            Pavel

            • 3. Re: 85% RQC UTILIZATION DETECTED FOR MONITOR CONTROLO
              Paul Robins

              We had a similar issue when we implemented Cosmos due to the number of nested rules. I agree with Irvan to consult with support before making any changes.