2 Replies Latest reply on Sep 15, 2017 4:06 PM by Scott Bleasdell

    All collected data log lines are ignored in Collection Status History window

    Raul Torres

      Hi,

       

      I'm trying to collect the content of a log with a content like this:

      01/09/2017 13:16:22 TCPX 012500 TCPE COMUNICA ON Error (78) en la conexion IP_Destino(192.168.235.254) Port(5040). TIME-OUT conexi

      01/09/2017 13:16:22 TCPX 012500 TCPE COMUNICA ON Error (78) en la conexion IP_Destino(192.168.235.254) Port(5040). TIME-OUT conexi

      01/09/2017 13:16:22 TCPX 012500 TCPE COMUNICA ON Error (78) en la conexion IP_Destino(192.168.235.254) Port(5040). TIME-OUT conexi

       

      After define the following Data Pattern:

      %{ITDADatePattern656:timestamp}\s+%{Data:Fuente}\s+%{SignedBase10Num:CodigoCaja}\s+%{Data:Recurso}\s+%{Data:IdRecurso}\s+%{Data:Suceso}\s+%{MultilineEntry:Detalle}

       

      And after define the associated Data Collector using SSH, all the log lines are ignored as I can see in Collection Status History window associated to the Data Collector.

       

      What is the problem? Why is ignored?

       

      Thanks in advance.

      Raúl

        • 1. Re: All collected data log lines are ignored in Collection Status History window
          Scott Bleasdell

          Raúl, I'm sorry for not responding sooner.  I was traveling and missed this post.  Let me try to reproduce this and I'll let you know what I find shortly.

          • 2. Re: All collected data log lines are ignored in Collection Status History window
            Scott Bleasdell

            Raúl, I tried this and did run into a snag that I think may be what you hit, but I did get this working.  First, here's the data pattern I created:

            Screen_Shot_2017-09-15_at_1_40_23_PM.png

            Note: I did update the date in your sample log data to today's date and time.  This doesn't affect anything, but just wanted to mention it.

             

            As you can see, the data pattern did work just fine.  Note that the Date Format dropdown (I have highlighted it in red) had to be set to the format that matches our date format - in this case that's dd/MM/yyyy HH:mm:ss.

             

            After that, I created the file /tmp/raul.log on my test system and created a data collector as shown here:

            Screen Shot 2017-09-15 at 1.47.35 PM.png

            As you can see, it read the sample content I put in the file by default, and matched that data with the "Raul" data pattern I created earlier.

             

            I created the data collector and then added one new line to the file.  In adding this line, I updated the time/date to the current time & date.  ITDA did pick up that new entry as you can see in the collection history window here:

            Screen Shot 2017-09-15 at 1.56.33 PM.png

            Can you try again and set your data pattern settings just as I show in these screenshots and let me know if that fixes your problem.  Also, I would be very interested in knowing exactly what the problem was, so please let me know.

             

            Thank you,

            Scott Bleasdell