4 Replies Latest reply on Sep 6, 2017 2:24 PM by Akshay D

    Unable to connect to CDP URL

    Akshay D

      Hello Team,

       

      I have installed BMC AO 7.6.03 on Windows, and able to access AM & REPO successfully, but not able to access the CDP Url;

      AM/REPO port: 9090

      CDP :28080

      Tomcat is working fine even including the ports. Getting following whenever tried to access,

      catalina.log

      The web application [/baocdp] created a ThreadLocal with key of type [com.sun.xml.bind.v2.runtime.Coordinator$1] (value [com.sun.xml.bind.v2.runtime.Coordinator$1@251c4123]) and a value of type [com.sun.xml.bind.v2.runtime.Coordinator[]] (value [[Lcom.sun.xml.bind.v2.runtime.Coordinator;@61f873dd]) but failed to remove it when the web application was stopped. This is very likely to create a memory leak.

       

      grid.log

      WARN  MessageFactory  : Can't find bundle for base name com.realops.foundation.gridframework.GridFrameworkMessages, locale en_US; fabricating bundle dynamically.

      ERROR ContextLoader   : Context initialization failed

      org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'cdpLauncher' defined in ServletContext resource [/META-INF/applicationContext.xml]: Invocation of init method failed; nested exception is com.bmc.ao.bootstrap.PeerLauncherException

      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1336)

       

      Tried the possible solutions mentioned on communities but not able to resolve.

      New Install- Cannot access grid manager

      Development Studio unable to connect to grid

       

      Kindly, suggest on the same,

       

      Thanks in advance,

      Akshay

        • 1. Re: Unable to connect to CDP URL
          Ranganath Samudrala

          How much resources (Memory, etc) do you have on that machine? May be you need to reinstall the CDP.

          • 2. Re: Unable to connect to CDP URL
            Akshay D

            Hi Ranganath,

             

            Thanks for the response,

            Server has 4CPU, 8GB RAM, Disk 180GB, Except re-install, what can be done to resolve this.

             

            Regards,

            Akshay

            • 3. Re: Unable to connect to CDP URL
              Ranganath Samudrala

              You may need to post the entire grid.log file here.

               

              Error messages in grid.log indicate that the installation did not go well. The WAR file baocdp.war is probably corrupt.You may even need to download the installer again.

               

              The reason why I asked for system resource information is that sometimes lack of resources will cause the installer download, creation and installation of tomcat and WAR file and explosion of the WAR may be affected. There may still be an issue in this installation process and reinstalling has resolved these kinds of problems.

              • 4. Re: Unable to connect to CDP URL
                Akshay D

                Hi Ranganath,

                 

                We create new baocdp.war file with same configurations and tried to deploy, but it was giving the same error.

                 

                We found some observations in Deploy.xml file & got the resolution for it,

                Deploy.xml was having entry of BladeLogic adapter configuration with User password having some special characters. So BAO was not able parse the XML with that special characters used in BSA password, which was causing error for CDP to get online. So, we replaced BSA user password with another password and restarted the CDP, then its started and the error resolved, but Bladelogic adapter in fault state.

                 

                Regards,

                Akshay