1 Reply Latest reply on Aug 22, 2017 1:35 PM by ryan nicosia

    Atrium Integrator REST Client step via HTTPS issue

    ryan nicosia

      I've seen a couple of threads regarding this but thought I'd pose the question.

       

      I've got REST Client step in Atrium Integrator transformation.  The destination is HTTPS and when I run the transformation I get the following error which seems to indicate a problem with my SSL configuration.

       

      PKIX path building failed: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBUilderException: unable to find valid certification path to requested target.

       

      Now, what I have done is go to the site which is a NetMRI (Infoblox) user interface.  I logged in via the web and then downloaded the certificate from Firefox.  I took that certificate and created a java keystore in the /java/bin directory on my machine where my transformation is running.

       

      I set the Trust Store file and password on the SSL tab of the REST Client step.

       

      HTTP Method:  GET

      Application Type: JSON

       

      I've tried just about every combination I can think of on the REST Client step with no luck.

       

      Has anybody ever got this working?  The only threads I have found show that people are using proxies or HTTPS tunnels to make it happen.