1 2 Previous Next 24 Replies Latest reply on Jul 14, 2017 1:20 PM by Sidhdesh Punaskar

    My 3.3.02 Survey does not work

    Sidhdesh Punaskar

      Hi Folks,

       

      We have configured MyIT 3.3.02 with survey functionality but it does not work.

      MyIT Survey Function

      3.3.02: Service Pack 2 - Digital Workplace Basic 3.3

       

      We have below configuration,

       

      1) We created a new survey with single question.

      2) Added the new survey in SRD.

      3) In admin console we enabled the survey but when we try to select the template it shows None.

      4) Also in user profile we have select survey notification.

       

      But on completion of SR we dont see survey in MyIT.

       

       

       

       

      In Remedy Survey is visible.

       

      Ux logs:

      Getting Survey Template for Srd with id 'SR005056B551A0UEuWSgSJhYBgT7UA'

      10:06:44.178 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.a.d.AbstractDataSource | Getting of user for param myit.arserveruser.MyIT-ITSM from the pool...

      10:06:44.178 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | replying with value=com.bmc.bsm.mobile.vo.profile.MobilityARUserPoolImpl@37846cb1

      10:06:44.178 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | Can't find request attribute myit.arserveruser.MyIT-ITSM from thread local

      10:06:44.178 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | value from request=null

      10:06:44.178 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | replying with request value=null

      10:06:44.178 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | Start to set request attribute myit.arserveruser.MyIT-ITSM

      10:06:44.178 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | Start to set request attribute myit.arserveruser.MyIT-ITSM for current thread

      10:06:44.181 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.a.d.AbstractDataSource | Getting of user for param myit.arserveruser.MyIT-ITSM.admin from the pool...

      10:06:44.181 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | replying with value=com.bmc.bsm.mobile.vo.profile.MobilityARUserPoolImpl@37846cb1

      10:06:44.181 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | Can't find request attribute myit.arserveruser.MyIT-ITSM.admin from thread local

      10:06:44.181 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | value from request=null

      10:06:44.181 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | replying with request value=null

      10:06:44.181 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | Start to set request attribute myit.arserveruser.MyIT-ITSM.admin

      10:06:44.181 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.i.Application | Start to set request attribute myit.arserveruser.MyIT-ITSM.admin for current thread

      10:06:44.185 | http-nio-80-exec-11            | RID: 8335 | WARN    | c.b.b.m.p.s.s.SrmSurveyService | No suitable survey templates were found. Returns null.

      10:06:44.187 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.myit.filter.ExpiresFilter | Request '/ux/rest/survey/applied_to/SR005056B551A0UEuWSgSJhYBgT7UA' with response status '204' content-type 'null', set expiration date Fri Jun 16 10:06:44 CEST 2017

      10:06:44.187 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.s.ApiKeyRequestListener | ApiKeyRequestListener.requestDestroyed: processing request.

      10:06:44.187 | http-nio-80-exec-11            | RID: 8335 | DEBUG   | c.b.b.m.s.ApiKeyRequestListener | ARServerUser objects were not registered - nothing to do

       

       

      I believe this is because we cannot select template for SRD in Admin console.

       

      What configuration are we missing?

       

      Sidhdesh

        1 2 Previous Next