6 Replies Latest reply on Jun 4, 2017 6:06 AM by Jens Heilmann

    Issue with BSA 8.8 and UEFI Boot

    Jens Heilmann

      Hi,

       

      in my test Environment i have create a dhcp Server with a uefi-config like the bsa 8.8 Dokumentation. I have also create a new System package with the Special Mountpoint /boot/efi.

      My VM-Ware-.Guest will run in to EFI-Boot and the Client can received the file boox64.efi over the bladelogic-tftp-Server. After this file the server search the tftp-bootfile like 0AFEA9.. . This special file is not create from the pxe-bl-Server. In a legacy PXE-Environment the pxe Server will create this Special file in pxelinux.0-Directory.

      In a EFI-Boot-Scenario this file are not create and the provisioning will be faild.

      My Question:

       

      What must i do. I have read the documention of BSA 8.8. But i cannot find any error.

       

      Have everybody running a uefi-provisioning over bladelogic 8.8 successfully?

       

      Thanks and regards,

       

      Jens Heilmann  

        • 1. Re: Issue with BSA 8.8 and UEFI Boot
          Newton Nyante

          Is this still outstanding with your UEFI testing?  Else what turned out to be the problem?

          • 2. Re: Issue with BSA 8.8 and UEFI Boot
            Jens Heilmann

            Hi,

             

            i have open two calls for two issues.

             

            Issue1: Bare-metal-prov with Redhat 6.7 or RH 7.3 on a VM-Ware-System with EFI enabled. The PXE-Server will not create the grub.conf file and the vm-System is booting in a grub-Shell. --> No provisioning

             

            Issue 2: Bare-metal-prov with Redhat 6.7 or RH 7.3 on a physical System (HP proliant BL 460 Gen9) with UEFI-enabled. The PXE-Server will create the grub.conf and the provisioning is running. But the defined kernel Options in the systempackage are not included in teh grub.conf file created by the PXE-Server.

            The kernel Options are importend if the internal raid-Controller running with the hpsa-Kernel-Modul. In this case i must blacklist the fc-Kernelmodules lpfc or qla2xxx. If i use a physical System with fibrechannel lun attached the Linux-kernel will use the first FC-LUN as /dev/sda and the installation will install the os on the fc-lun and not on the internal disk.

             

            I use this kernel Options:

             

             

            lang=en_US keymap=de_latin1 vga=792 noipv6 text rdloaddriver=hpsa rdblacklist=qla2xxx,lpfc ifname=eth0:??DEVICE.PB_MAC??

             

             

             

            the pxe-Server create this file if the physical System running in uefi

             

             

            cat 0AFE018B

             

            default=0

             

            timeout=1

             

            splashimage=(nd)/../../EFI/RedHat/splash.xpm.gz

             

            hiddenmenu

             

            title Redhat

             

            root (nd)

             

            kernel /../../X86PC/pxelinux/rhel66/vmlinuz  ks=http://10.254.1.170/repos/5C-B9-01-CB-53-80 ksdevice=eth0

             

            initrd /../../X86PC/pxelinux/rhel66/initrd.img

             

            the correct file must have the follow entries:

             

             

            lang=en_US keymap=de_latin1 vga=792 noipv6 text rdloaddriver=hpsa rdblacklist=qla2xxx,lpfc ifname=eth0:5c:b9:01:cb:53:80 ks=http://10.254.1.170/repos/5C-B9-01-CB-53-80 ksdevice=eth0

             

             

            I think this is a bug.

             

            Kind regards,

             

            Jens Heilmann

             

            • 3. Re: Issue with BSA 8.8 and UEFI Boot
              Bill Robinson

              i'm not sure i see the bug.  the boot args in red look the same as what you supplied.

               

              "But the defined kernel Options in the systempackage are not included in teh grub.conf file created by the PXE-Server."

              -> afaik the boot args you pass in the system package are to boot the system, not passed through to the 'bootloader' kickstart option.  and that has nothing to do w/ uefi.

              • 4. Re: Issue with BSA 8.8 and UEFI Boot
                Jens Heilmann

                 

                Hi Bill,

                 

                 

                 

                 

                please see the Documentation BSA 8.8

                 

                 

                 

                 

                Boot Kernel Parameters

                 

                Additional boot time kernel parameters you would like to use for the server. Some commonly used parameters include:

                 

                nofb — This command disables frame buffer support and allows the installation program to run in text mode. This command may be necessary for accessibility with some screen reading hardware.

                skipddc — This x86 boot command skips the ddc monitor probe which causes issues on some systems.

                For a full list of available boot kernel parameters, see your Linux platform installation documentation.

                 

                 

                If I use a system in legacy bios mode then the pxe-server create the bootp-File with "boot kernel parameters" included.

                 

                 

                legacy  BIOS

                 

                cat 0AFE01A8

                 

                # Perform a local boot by default

                 

                default run-autodetect

                 

                # Always prompt

                 

                prompt 1

                 

                # Display the bootup message

                 

                display pxeboot.msg

                 

                # Boot automatically after 300 seconds

                 

                timeout 1

                 

                label local

                 

                localboot 0

                 

                # The rest of this file is machine-generated

                 

                label run-autodetect

                 

                kernel rhel67/vmlinuz

                 

                append initrd=rhel67/initrd.img lang=en_US devfs=nomount ramdisk_size=16384 lang=en_US keymap=de_latin1 noipv6 text rdloaddriver=hpsa rdblacklist=qla2xxx,lpfc ifname=eth0:00:50:56:00:ae:0a ks=http://10.254.1.170/repos/00-50-56-00-AE-0A ksdevice=00:50:56:00:ae:0a

                 

                 

                If the same system configured with uefi-bios-mode the pxe-server create the bootp file without the defined "boot kernel parameters" from the system package.

                 

                 

                Cat 0AFE01A8

                 

                default=0

                 

                timeout=1

                 

                splashimage=(nd)/../../EFI/RedHat/splash.xpm.gz

                 

                hiddenmenu

                 

                title Redhat

                 

                root (nd)

                 

                kernel /../../X86PC/pxelinux/rhel66/vmlinuz ks=http://10.254.1.170/repos/00-50-56-00-AE-0A ksdevice=eth0

                 

                initrd /../../X86PC/pxelinux/rhel66/initrd.img

                 

                 

                I have create the correct bootp-file with "boot kernel parameters" included manually.

                 

                 

                default=0

                 

                timeout=1

                 

                splashimage=(nd)/../../EFI/RedHat/splash.xpm.gz

                 

                hiddenmenu

                 

                title Redhat

                 

                root (nd)

                 

                kernel /../../X86PC/pxelinux/rhel66/vmlinuz lang=en_US keymap=de_latin1 ipv6.disable=1 selinux=0 inst.text modprobe.blacklist=lpfc,qla2xxx latefcload nostorage net.ifnames=0 ifname=eth0:00:50:56:00:ae:0a scsi_mod.max_luns=8191 scsi_mod.max_report_luns=8192 ks=http://10.254.1.170/repos/00-50-56-00-AE-0A ksdevice=eth0

                 

                initrd /../../X86PC/pxelinux/rhel66/initrd.img

                 

                 

                This config are working perfectly. The System are installed in text-mode, ipv6, selinux are disabled, Keyboard is german and the kernelmodules for lpfc and qla2xxx are not loaded.

                 

                 

                So I think this is a bug and uefi boot are not working if the target a vmware-system in efi-mode.

                 

                 

                Kind Regards,

                 

                 

                 

                Jens Heilmann

                1 of 1 people found this helpful
                • 5. Re: Issue with BSA 8.8 and UEFI Boot
                  Bill Robinson

                  oh - i see.  yeah - if the kernel boot args aren't getting passed through that seems like a problem.

                  • 6. Re: Issue with BSA 8.8 and UEFI Boot
                    Jens Heilmann

                    Hi,

                     

                    short update:

                     

                    1.) VMWare-Guest with uefi-Boot enabled are not work: Yes there is a Bug in Bladelogic. BMC have create a Hotfix for me. Now this issue is solved. ESX-Client in UEFI-Mode use Arch 0009 over DHCP. The BL-PXE-Server will not accept this Arch-Type. This is the problem. BMC know this issue and can create a Hotfix.

                     

                    2.) BL-Pxe-Servr will not create a Bootp-File with the Kernel options, there are defined in the system packages. This is a Bug. BMC will solve this issue in BL 8.9 Service Pack 2. SP2.