10 Replies Latest reply on Jan 3, 2017 4:10 PM by Bill Robinson

    Failed to copy file of the blpackage on Deploy

    Natali Nogueira

       

       

       

       

       

      Info24/10/2016 11:14:03Deploy Apply Job (Pre-Execute):SINCAD App Bin (TESTE); Server:X;  PkgID:"36f682ec-f93b-46cb-b02c-1e8445aedbb8-2033123.13"; UUID:44a30f328c5936af82e24ad5a33e81bd
      Info24/10/2016 11:14:03Started running the deploy step job 'SINCAD App Bin (TESTE)->SINCAD App Bin (TESTE)' on application server 'host1-job-server-appserver1'(2,007,300) against target server 'X'
      Error24/10/2016 11:14:04Failed to copy: Source: /tmp/stage/093a0a5a707a37f7b79f61ee8d25e2b7/7ed3c243b42ad31df2b0dce512c6a2681477314735530959454270 Dest: /<directory>: No such file or directory2.1.1.1<directory>
      Error24/10/2016 11:14:04Apply failed: id = 2.1.1.12.1.1.1<directory>
      Error24/10/2016 11:14:04Apply failed, no auto rollback.
      Warning24/10/2016 11:14:04Deploy failed. Cleaning up staging area.
      Error24/10/2016 11:14:10APPLY failed for server X. Exit code = -4001
      Info24/10/2016 11:14:10The job 'SINCAD App Bin (TESTE)->SINCAD App Bin (TESTE)' has failed on server X

       

       

      This happens when the package is being created by adding some files and saved only at the end of the package edition.

      When we are editing and saving each file added to blpackage, the error doesn't happen.

        • 1. Re: Failed to copy file of the blpackage on Deploy
          Bill Robinson

          if you look in the file server, where the blpackage is, do you see the added files when you add a bunch at once and then save ?

          • 2. Re: Failed to copy file of the blpackage on Deploy
            Natali Nogueira

            I don't check the file server during  the blpackage creation.

            We create the bkpackage and save. But we noticed this behavior in some files.

            • 3. Re: Failed to copy file of the blpackage on Deploy
              Bill Robinson

              how are the packages created normally? via the gui?  going through a load balancer?  some other way ?  it would seem like something is going wrong when the package is created, or something is removing the file after it's on the file server.

              • 4. Re: Failed to copy file of the blpackage on Deploy
                Ashish Vijay

                I get this kind of error sometime when file on File Server is corrupted. So go and check if md5 of file on file server and original file is same.

                • 5. Re: Failed to copy file of the blpackage on Deploy
                  Natali Nogueira

                  The packages were created normally by gui.

                  The application server has two servers, but no in load balance.

                  And the File Server is not corrupted.

                  We noticed this error, always the packages are created and saved on the end of edition.

                  When I create a package and save it on each imported item/file, this doesn't happen.

                  • 6. Re: Failed to copy file of the blpackage on Deploy
                    Bill Robinson

                    "We noticed this error, always the packages are created and saved on the end of edition."

                    can you reliably reproduce that?  if so there may be things in the appserver log or other places to look at to get a clue what is happening.

                    and what version of bsa is this ?

                    • 7. Re: Failed to copy file of the blpackage on Deploy
                      Natali Nogueira

                      We tested on two version os BSA: 8.5 and 8.8.

                      The error always happens.

                       

                      1º execution - Deploy of only directories - OK

                      2º execution - Import all files on directory and save package in the end of edition - ERROR

                      3º execution - Import all files on directory and saved blpackage on each step - OK

                       

                       

                       

                      SUCCESS LOG:

                       

                      12/02/16 13:10:20.445 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] _CreateDirectory : /tmp/p1/file.properties Top

                      12/02/16 13:10:20.445 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] Using standard file.

                      12/02/16 13:10:20.445 DEBUG    bldeploy - [1.1][/tmp/p1file.properties] DEBUG - not a symlink

                      12/02/16 13:10:20.445 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] IsFileExists(/tmp/p1/file.properties) = 0

                      12/02/16 13:10:20.446 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] Chmod /tmp/p1/file.properties 666

                      12/02/16 13:10:20.446 DEBUG    bldeploy - [1.1][/tmp/p1file.properties] createTime=1480450670 accessTime=0 modifyTime=1479930858

                      12/02/16 13:10:20.446 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] Set time on file /tmp/p1/file.properties

                      12/02/16 13:10:20.447 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] Success - removed acl /tmp/p1/file.properties

                      12/02/16 13:10:20.447 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] FileAdd: Success FileName: /tmp/p1/file.properties

                       

                       

                      FAILURE LOG:

                       

                      12/02/16 12:57:54.852 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] _CreateDirectory : /tmp/p1/file.properties Top

                      12/02/16 12:57:54.853 DEBUG    bldeploy - [1.1][/tmp/p1file.properties] Using standard file.

                      12/02/16 12:57:54.853 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] DEBUG - not a symlink

                      12/02/16 12:57:54.853 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] IsFileExists(/tmp/p1/file.properties) = 0

                      12/02/16 12:57:54.854 ERROR    bldeploy - [1.1][/tmp/p1/file.properties] Failed to copy: Source: /var/tmp/stage/7ccfb48dd333370dacceb435918dcea2/3719a58e54f0c83417d6a7c431ea614314806903223061773198200 Dest: /tmp/p1/file.properties: No such file or directory

                      12/02/16 12:57:54.854 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] FileAdd:: Apply failed

                      12/02/16 12:57:54.855 ERROR    bldeploy - [1.1][/tmp/p1/file.properties] Apply failed: id = 1.1

                      12/02/16 12:57:54.855 DEBUG    bldeploy - [1.1][/tmp/p1/file.properties] Apply failed -processing sub-list: id = 1.1

                      12/02/16 12:57:54.855 DEBUG    bldeploy - [1][/tmp/p1] Apply failed -processing sub-list: id = 1

                      12/02/16 12:57:54.855 DEBUG    bldeploy - [][] Package failed = BLPACKAGE

                       

                      Thank you.

                      • 8. Re: Failed to copy file of the blpackage on Deploy
                        Bill Robinson

                        if you can reliably reproduce the problem then i would open a support ticket so we can investigate.

                        • 9. Re: Failed to copy file of the blpackage on Deploy
                          Natali Nogueira

                          I already open a support ticket about this error.