7 Replies Latest reply on Oct 12, 2016 4:08 AM by Ali SIMON

    Deploy job OK but status is failed with exit code 0

    Ali SIMON

      Hello,

       

      BSA 8.7P2

      Target : Linux x64

      I have a very simple deploy job that's exiting in error each time.

      It consist of a BLPackage which does the following :

      1. Put 2 zip files to client server
      2. External CMD : unzip silently in specified directory

       

      Everything is working as expected (files deployed, and unzipped), but still the status is failed, although the return & exit codes are OK

       

      I have activated debug mode but it doesn't help.

       

      It's driving me nuts.

      In the below run, I have commented out the file deploy, because they're still in the target directory, so I only execute item 4 of the blpackage which is the unzip command.

      Info09/26/2016 11:58:08Deploy Apply Job (Pre-Execute):ASN_1 - Install ANT-LNX; Server:xxxx;  PkgID:"338888b5-ea3a-4d3b-8e63-9401ce677e04-2232861.5"; UUID:fd5ab359077e3e25b424dc5c7758d509
      Info09/26/2016 11:58:08Started running the deploy step job 'ASN_1 - Install ANT-LNX->ASN_1 - Install ANT-LNX' on application server 'bl_jobsrv5-dc1'(2,011,023) against target server 'xxxx'
      Info09/26/2016 11:58:10Package "ASN_BL-BOOTSTRAP-LNX" UUID(fd5ab359077e3e25b424dc5c7758d509) started
      Info09/26/2016 11:58:11Package "ASN_BL-BOOTSTRAP-LNX" UUID(fd5ab359077e3e25b424dc5c7758d509) initialized, entering wait queue for processing
      Info09/26/2016 11:58:11Package "ASN_BL-BOOTSTRAP-LNX" UUID(fd5ab359077e3e25b424dc5c7758d509) processing instructions
      Info09/26/2016 11:58:17Deployment job not in single-job mode. Reboot and single-user mode is not allowed  (Time in agent's deploy log:: 09/26/2016 11:58:08)
      Info09/26/2016 11:58:17Bldeploy "ASN_BL-BOOTSTRAP-LNX" UUID(fd5ab359077e3e25b424dc5c7758d509) started using file /var/tmp/stage/d767710bf24a382abec95b384754c896/bldeploy.xml with rollback directory /usr/nsh/RSCD/Transactions/fd5ab359077e3e25b424dc5c7758d509  (Time in agent's deploy log:: 09/26/2016 11:58:09)
      Info09/26/2016 11:58:17Starting apply (Time in agent's deploy log:: 09/26/2016 11:58:09)
      Info09/26/2016 11:58:17Processing asset BLPACKAGE (Time in agent's deploy log:: 09/26/2016 11:58:09)
      Info09/26/2016 11:58:17Processing asset EXTERNALCMD (Time in agent's deploy log:: 09/26/2016 11:58:09)4Deploy
      Info09/26/2016 11:58:17Executing command: "unzip -q /deploy/BL-BOOTSTRAP/ant.zip -d /softs/bladelogic/ant (Time in agent's deploy log:: 09/26/2016 11:58:09)4Deploy
      Info09/26/2016 11:58:17unzip -q /deploy/BL-BOOTSTRAP/j2sdk-lnx.zip -d /softs/bladelogic/java"
      Info09/26/2016 11:58:17Apply Succeeded  (Time in agent's deploy log:: 09/26/2016 11:58:10)
      Info09/26/2016 11:58:17Registering DDA plugin (Time in agent's deploy log:: 09/26/2016 11:58:10)
      Info09/26/2016 11:58:17Registered DDA plugin  (Time in agent's deploy log:: 09/26/2016 11:58:10)
      Info09/26/2016 11:58:17Initializing plugin globals  (Time in agent's deploy log:: 09/26/2016 11:58:10)
      Info09/26/2016 11:58:17Initializing Plugin object (Time in agent's deploy log:: 09/26/2016 11:58:10)
      Info09/26/2016 11:58:17Bldeploy done - nRet = 1 (Apply successful) exitCode = 0 (Deployment succeeded) (Time in agent's deploy log:: 09/26/2016 11:58:10)
      Error09/26/2016 11:58:18APPLY failed for server xxxx. Exit code = 0
      Info09/26/2016 11:58:18The job 'ASN_1 - Install ANT-LNX->ASN_1 - Install ANT-LNX' has failed on server xxxx

       

       

      Any advices ?

      Thank you.