5 Replies Latest reply on Sep 1, 2016 8:14 AM by Bill Robinson

    blquery config_record_count not working

    Sae Park

      I'm trying to use blquery config_record_count, but doesn't seem to be working at all.

      Just wondering if anyone had same experience.

      I'm using BSA 8.6.1

      Here is my command: blquery -h sol10imp -e 'config_record_count ("/etc/passwd")'

      There are 31 entries, but it returns -1

      I've tried against different operating systems, such as Linux, Solaris and HP-UX with different number of entries, but they all return -1.

      Anyone have an idea by any chance?

       

      Thanks!

        • 1. Re: blquery config_record_count not working
          Bill Robinson

          Works for me, linux nsh to linux target.  anything in the rscd log on the target ?

          what os is the nsh client ?

          • 2. Re: blquery config_record_count not working
            Sae Park

            Here is what I see from a target machine running Linux:

            bfb678ec955b64698210 0000001184 08/23/16 10:16:15.609 INFO     rscd -  ::ffff:10.80.4.7 12073 0/0 (BLAdmins:[hidden]): blquery: C:\Program Files\BMC Software\BladeLogic\NSH\bin\blquery.exe -D //sysadm -h sysadm -e config_record_count ("/etc/passwd")

             

            Here is another one running Solaris:

            e6d62632e74034027f08 0000000962 08/23/16 10:14:53.610 INFO     rscd -  ::ffff:10.80.4.7 9334 0/0 (BLAdmins:[hidden]): blquery: C:\Program Files\BMC Software\BladeLogic\NSH\bin\blquery.exe -h sol10imp -e config_record_count ("/etc/passwd")

            • 3. Re: blquery config_record_count not working
              Bill Robinson

              works for me from windows as well.  agent log in debug mode might catch something (agentctl toggle) ?  are you going through a nsh proxy or anything ?

              • 4. Re: blquery config_record_count not working
                Sae Park

                Here is what I get with debug mode:

                97d75367abe001220206 0000000970 08/23/16 13:18:25.311 DEBUG    rscd -  sol10imp 12389 -1/-1 (Not_available): (Not_available): FIPS Disabled

                95c3a786e0a434fe7d05 0000000971 08/23/16 13:18:25.355 DEBUG    rscd -  ::ffff:10.80.4.7 12389 -1/-1 (Not_available): (Not_available): Enabling keepalive on the connection

                b96d43aca6350397c7b4 0000000972 08/23/16 13:18:25.355 DEBUG    rscd -  sol10imp 12389 -1/-1 (Not_available): (Not_available): Waiting for a command

                578d85d05e4b95e47125 0000000973 08/23/16 13:18:25.966 DEBUG    rscd -  sol10imp 12389 -1/-1 (Not_available): (Not_available): Received command:101 with arg:0;0;1a;BLAdmins:[hidden];7;blquery;-;-;0;-;1;1;7;bladmin;CP1252;

                aecb1e780a25f58be69d 0000000974 08/23/16 13:18:25.985 DEBUG    rscd -  ::ffff:10.80.4.7 12389 0/0 (BLAdmins:[hidden]): blquery: ***** New connection *****

                abe9c61e179c32c1690e 0000000975 08/23/16 13:18:25.989 INFO     rscd -  ::ffff:10.80.4.7 12389 0/0 (BLAdmins:[hidden]): blquery: C:\Program Files\BMC Software\BladeLogic\NSH\bin\blquery.exe -h sol10imp -e config_record_count ("/etc/passwd")

                27195ed201ce61464633 0000000976 08/23/16 13:18:25.991 INFO2    rscd -  ::ffff:10.80.4.7 12389 0/0 (BLAdmins:[hidden]): blquery: uname () = 1

                 

                I am going through a proxy, but should that make any difference?

                • 5. Re: blquery config_record_count not working
                  Bill Robinson

                  going through a proxy shouldn't matter. is this system using centrify or ldap auth ?