7 Replies Latest reply on Aug 25, 2016 3:16 AM by Yogeesh Kompa

    Errors while running ETL in BDSSA

    Yogeesh Kompa
      Share This:

      Dear All,

       

      I have recently created a user and gave the roles of  "GlobalReportAdmins" and "GlobalReportViewers", so that user can run reports in BDSSA.

       

      After that I tried to ran RBAC ETL in BDSSA server via Network shell and ended up with below error.

      RBAC ETL Error.jpg

      Error says Site ID cannot be null. But when I cross check the site, the site has the ID as "1" . Please find below screenshots.

      Site_ID.jpg

      Site_ID_1.jpg

       

      Please let me know how to fix this issue.

       

      Regards,

      Yogeesh

        • 1. Re: Errors while running ETL in BDSSA

          Try putting a space between the argument name and value:

           

          nsh run_etl.nsh -s 1 -v 82 -f rbac.properties

          • 2. Re: Errors while running ETL in BDSSA
            Yogeesh Kompa

            Hi Jim,

             

            I have tried even with space. Still the same error. Please find below screenshot.

             

            Run ETL.jpg

             

            Regards,

            Yogeesh

            • 3. Re: Errors while running ETL in BDSSA
              Bill Robinson

              where did you start nsh from - are you on the bdssa system itself ?  you did not start nsh from some other system and cd to the bdssa server?

               

              can you run:

               

              nsh -x run_etl.nsh -s 1 -v 82 -f rbac.properties

               

              and show the output ?

              • 4. Re: Errors while running ETL in BDSSA
                Yogeesh Kompa

                Hi Bill,

                 

                I am starting nsh from BDSSA system itself.

                 

                Below is the output of the RBAC ETL ran ( nsh -x run_etl.nsh -s 1 -v 82 -f rbac.properties)

                 

                BDSSA_SERVER% nsh -x run_etl.nsh -s 1 -v 82 -f rbac.properties

                +run_etl.nsh:15> [ 6 -eq 0 ']'

                +run_etl.nsh:21> echo 'Starting run_etl.'

                Starting run_etl.

                +run_etl.nsh:24> CTX=''

                +run_etl.nsh:25> SITE=''

                +run_etl.nsh:26> LVL_PRL=''

                +run_etl.nsh:27> LOGLEVEL=''

                +run_etl.nsh:28> OM_VER=''

                +run_etl.nsh:29> PROPERTIES_FILENAME=''

                +run_etl.nsh:30> BPID_ARRAY=''

                +run_etl.nsh:31> SCEN_LIST=''

                +run_etl.nsh:32> LOGVALUE=''

                +run_etl.nsh:33> ERROR_FLAG=0

                +run_etl.nsh:34> DOMAIN_LIST=''

                +run_etl.nsh:35> SYNC_LIST=''

                +run_etl.nsh:36> PLATFORM=''

                +run_etl.nsh:39> getopts :s:d:v:f:p:l: Option

                +run_etl.nsh:63> [ 'C:\Program Files\BMC Software\BladeLogic\Reports' '=' '' ']'

                 

                 

                +run_etl.nsh:79> REPORTS_HOME_PATH=+run_etl.nsh:1> echo -E 'C:\Program' 'Files\BMC' 'Software\BladeLogic\Reports'

                +run_etl.nsh:79> REPORTS_HOME_PATH='C:\Program Files\BMC Software\BladeLogic\Reports'

                +run_etl.nsh:1> echo 'C:\Program Files\BMC Software\BladeLogic\Reports'

                +run_etl.nsh:1> wc -l+run_etl.nsh:1> grep :

                +run_etl.nsh:81> [ 1 -gt 0 ']'

                +run_etl.nsh:83> REPORTS_HOME_PATH=+run_etl.nsh:1> echo -E 'C:\Program Files\BMC  Software\BladeLogic\Reports'

                +run_etl.nsh:83> REPORTS_HOME_PATH=+run_etl.nsh:1> sed 's/\://g'

                +run_etl.nsh:83> REPORTS_HOME_PATH=+run_etl.nsh:1> tr '\' /

                +run_etl.nsh:83> REPORTS_HOME_PATH=+run_etl.nsh:83> REPORTS_HOME_PATH=+run_etl.n

                sh:1> sed 's/\/\//\//g'+run_etl.nsh:1> tr -d :

                +run_etl.nsh:83> REPORTS_HOME_PATH='C/Program Files/BMC Software/BladeLogic/Reports'

                +run_etl.nsh:84> REPORTS_HOME_PATH='/C/Program Files/BMC Software/BladeLogic/Reports'

                +run_etl.nsh:88> [ ! -e '/C/Program Files/BMC Software/BladeLogic/Reports/bin/odi_settings.properties' ']'

                +run_etl.nsh:96> ETL_BIN_PATH=+run_etl.nsh:96> ETL_BIN_PATH=+run_etl.nsh:1> grep

                odiInstallationPath '/C/Program Files/BMC Software/BladeLogic/Reports/bin/odi_settings.properties'+run_etl.nsh:1> cut -d '=' -f 2

                +run_etl.nsh:96> ETL_BIN_PATH='C:/Program Files/BMC Software/BladeLogic/Reports/etl/bin'

                +run_etl.nsh:1> echo 'C:/Program Files/BMC Software/BladeLogic/Reports/etl/bin'

                +run_etl.nsh:1> wc -l

                +run_etl.nsh:1> grep :

                +run_etl.nsh:98> [ 1 -gt 0 ']'

                +run_etl.nsh:100> ETL_BIN_PATH=+run_etl.nsh:1> grep odiInstallationPath '/C/Program Files/BMC Software/BladeLogic/Reports/bin/odi_settings.properties'

                +run_etl.nsh:100> ETL_BIN_PATH=+run_etl.nsh:1> cut -d '=' -f 2

                +run_etl.nsh:100> ETL_BIN_PATH=+run_etl.nsh:1> sed 's/\://g'

                +run_etl.nsh:100> ETL_BIN_PATH=+run_etl.nsh:1> tr '\' /

                +run_etl.nsh:100> ETL_BIN_PATH=+run_etl.nsh:100> ETL_BIN_PATH=+run_etl.nsh:1> se

                d 's/\/\//\//g'+run_etl.nsh:1> tr -d :

                +run_etl.nsh:100> ETL_BIN_PATH='C/Program Files/BMC Software/BladeLogic/Reports/etl/bin'

                +run_etl.nsh:101> ETL_BIN_PATH='/C/Program Files/BMC Software/BladeLogic/Reports/etl/bin'

                +run_etl.nsh:104> [ ! -d '/C/Program Files/BMC Software/BladeLogic/Reports/etl/bin' ']'

                +run_etl.nsh:112> CURRENT_PATH=+run_etl.nsh:1> pwd

                +run_etl.nsh:112> CURRENT_PATH='/c/Program Files/BMC Software/BladeLogic/Reports/etl/bin'

                +run_etl.nsh:116> echo 'Parameter verification: '

                Parameter verification:

                +run_etl.nsh:117> echo '    Site Id: '

                    Site Id:

                +run_etl.nsh:118> echo '    OM Version: '

                    OM Version:

                +run_etl.nsh:122> [ '' '=' '' ']'

                +run_etl.nsh:124> echo 'ERROR: Site Id cannot be null. Please enter a valid Site

                Id.'

                ERROR: Site Id cannot be null. Please enter a valid Site Id.

                +run_etl.nsh:125> echo 'ETL is terminating with an error.'

                ETL is terminating with an error.

                +run_etl.nsh:126> exit 1

                 

                Regards,

                Yogeesh

                • 5. Re: Errors while running ETL in BDSSA
                  Yogeesh Kompa

                  Hi Bill,

                   

                  Any findings/suggestion? Even I am trying to figure out from my end.

                  • 6. Re: Errors while running ETL in BDSSA
                    Bill Robinson

                    can you use the unix path syntax when you cd into the bin dir - eg

                     

                    cd /C/Program Files/BMC Software/...

                     

                    instead of the windows style you are using.

                    • 7. Re: Errors while running ETL in BDSSA
                      Yogeesh Kompa

                      Hi Bill,

                       

                      Thanks for the response. I did the below things and sorted out the issue.

                       

                      I cross verified the Site ID in  the database and I was able to see the SIte ID field value as 1. So everything was fine at DB level.

                       

                      Next, I tried running the ETL via normal command prompt rather than via NSH.

                       

                      First I tried to stop all the ETL which was running (just to make sure nothing is running in the backend or just to kill the ETL that got stuck)

                      %BDSSA_HOME%\etl\bin>nsh stop_etl.nsh -s1 -v

                      Stopping ETL.

                      Parameter verification:

                          Site Id:  1

                          OM Version:  82

                      Navigating to ETL path...

                      Navigating to ETL path - Completed.

                      Removing orphaned exstat files.

                      Finished removing orphaned exstat files.

                      Checking lock file for Site Id: 1

                      Lock file props.lock does not exist.

                      Lock file does not exist

                      Proceeding with Database Reset.

                      Stop ETL is successful.

                       

                      Later I started ETL (nsh run_etl.nsh -s1 -v82 -f rbac.properties) and it was successful.

                      Starting run_etl.

                      Parameter verification:

                          Site Id:  1

                          OM Version:  82

                          Log Level:  3

                          Level of Parallelism:  20

                          Override Flag for Cognos Update:  0

                          Properties Filename:  rbac.properties

                      Navigating to ETL path...

                      Completed.

                      Proceeding with ETL ...

                      ETL has completed succesfully.

                       

                      So issue got fixed after stopping all ETL (stop_etl.nsh).

                       

                       

                      Thanks & Regards,

                      Yogeesh

                      1 of 1 people found this helpful