3 Replies Latest reply on Aug 10, 2018 2:17 PM by Jon Trotter

    Do you suffer from "tw_report: not found"?

      Hi ADDM-Users!

       

      In our installation of ADDM 10.2, we suffer from problems in discovery, especially for Solaris 11 Machines. In many cases, we get an error message saying "tw_report: not found" (if we run with ksh) or "tw_report: command not found" (bash).

       

      What is your experience? Do you have the same problem, or is it only us?

       

      With this query, you can quickly check your ADDM for this issue:

          search DiscoveredCommandResult where result has subword 'tw_report:' and result has subword 'not found'

       

      Background:

      tw_report is a shell function defined in the platform discovery. It is used to report discovered data back to ADDM. If you find "tw_report: not found", you will probably have incomplete data in your scan.

       

       

      Thank you for your input to learn about the disseminitation of that issue.

       

        Peter

        • 1. Re: Do you suffer from "tw_report: not found"?
          Andrew Waters

          Have you tried setting "force subshell" for the credential you use to discover the Solaris machines. Solaris ksh appears to occasionally lose characters which can result in this error.

          • 2. Re: Do you suffer from "tw_report: not found"?

            The shell does'nt lose characters if used correctly. It's nomal that there are limitations on the input buffer, and the person or script writing commands into the shell interactively (which is simulated by ADDM) must take care for this.

             

            I really believe there is something broken in the interaction between the scanner and the scanned machine. I'm betting on some kind of over-optimisation, which pumps more commands into the target host than it can process, leading in lost bytes in the buffer.

             

            I'm working with the support on this issue, and I have tried many, many different options. Changing the shell to bash, setting the session time limit, force subshell on/off. None of them worked 100% or is acceptable, and I have serious problems with "reducing the chance this issue occurs", which translates to me as "pah, be happy that 99% works - it could be worse!".

             

            I have a very good solution, which removes the problem absolutely reliable, but that's not enough for me. It's still a workaround. I want BMC to fix the PROBLEM.

             

            My request is: how many other customers suffer from this issue? If I know of a bunch of other customers, we can probably make BMC fix the underlying bug, resulting in a more reliable product - that's something, we all want, I assume.

            1 of 1 people found this helpful
            • 3. Re: Do you suffer from "tw_report: not found"?
              Jon Trotter

              Haven't noticed this issue until just now, we have seen this happen very randomly and infrequently but it still happens. We do not have the Force Shell option turned on. Interested to see if this is still an issue or if a "solution" has been provided?