5 Replies Latest reply on Mar 11, 2016 7:03 PM by Raja Mohan

    reg_value in EO

    Raja Mohan


      I created an extended object under config object dictionary, the command works from nsh command line but when I do the same under object dictionary it seems to lose the blank space on "Internet Explorer" and doesn't produce any output.


      the command/script under extended object with central execution set as execution type

      blquery -h ??TARGET.HOST?? -e 'reg_value("HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\Internet Explorer\\Version")'


      from the live browse and looking at the "Extended Objects" it looks like this



      Should I need to escape the blank space? Is there a way to escape the blank space? I tried \\ but it didn't work.


      thanks in advance,


        • 1. Re: reg_value in EO
          Raja Mohan

          ok, Looking at the appserver logs it seems like the single quote is removed when executing, thereby command looks incomplete.


          snippet from log

          [Client] Started pid 25872: blquery -h xxxxxx -e reg_value ("HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\Internet Explorer\\Version")


          This is on version 8.3Sp2

          • 2. Re: reg_value in EO
            Bill Robinson

            You have that directly in the EO box ?  why aren’t you using the native registry object for this ?

            • 3. Re: reg_value in EO
              Raja Mohan

              Bill Robinson that is where I first started, but I don't see the data in BDSSA under Inventory/Windows/Registry.


              I created a part, browsed to a server and selected the registry I wanted to look for in the template. After that using the template I ran a discover and snapshot jobs, followed by ETL. I receive a "No
              data available
              " anytime I add anything under registry. Am I looking at the wrong location?

              • 4. Re: reg_value in EO
                Bill Robinson

                Enabling Inventory assets - BMC Decision Support for Server Automation 8.7 - BMC Documentation


                By default, the data for the following assets is not loaded from the BMC Server Automation database to the reports data warehouse. Additionally, data for these assets is not migrated to BMC Decision Support for Server Automation version 8.7 from earlier releases. Therefore, you cannot see data for these assets in the built-in and ad hoc Inventory reports.

                • File System
                • Registry
                • .NET Assemblies

                To enable the data loading and migration of these assets, you must run the scripts


                • 5. Re: reg_value in EO
                  Raja Mohan

                  I found the schema on a different location than what is on the documentation /reports/contents/db/scripts/oracle/schema and have requested for the update to database. I will keep posted once I am able to test after the schema change.








                  thanks for the help