2 Replies Latest reply on Feb 12, 2016 2:44 PM by richard mcleod

    Unable to create BlPackage using blcli... possibly corrupt object?

    richard mcleod

      Not sure whats going on here but I am stumped... I am trying to create this blank blpackage using blcli. weird that it says a JOB already exists, not sure how a job can exist in the depot.

       

      host% blcli_execute BlPackage createEmptyPackage "Get-Username.psm1" "PowerShellModules/C/Windows/System32/WindowsPowerShell/v1.0/Modules/BBWINSA.Utils/Get-Username.psm1" "2010842"

      Command execution failed. com.bladelogic.om.infra.mfw.util.BlException: A job with the name 'Get-Username.psm1' already exists in this group.

       

       

      I tried this in the gui as well, same error message. So then I said maybe I can access the object that exists...

       

      host% blcli_execute BlPackage getDBKeyByGroupAndName "/path/production/source/blpackages/PowerShellModules/C/Windows/System32/WindowsPowerShell/v1.0/Modules/BBWINSA.Utils" "Get-Username.psm1"

      Command execution failed. com.bladelogic.om.infra.mfw.util.BlException: Cannot find depot object by name : Get-Username.psm1

      in group : BBWINSA.Utils with type : BLPACKAGE

       

       

      Maybe we can delete it?

      host% blcli_execute DepotObject deleteDepotObjectByTypeStringGroupAndName "BLPACKAGE" "/path/production/source/blpackages/PowerShellModules/C/Windows/System32/WindowsPowerShell/v1.0/Modules/BBWINSA.Utils" "Get-Username.psm1"

      Command execution failed. com.bladelogic.om.infra.mfw.util.BlException: Cannot find depot object by name : Get-Username.psm1

      in group : BBWINSA.Utils with type : BLPACKAGE

       

      Any ideas?