4 Replies Latest reply on Feb 19, 2016 8:46 AM by Daniel Suen

    Server getBulkServerPropertyValuesAndLogResults - "Command execution failed. com.bladelogic.om.infra.mfw.util.BlException: 1"

    Daniel Suen

      I originally wrote a Type 4 Perl NSH script, where I kind of imitate previous posting to do


      1. use the passed-in hostnames, construct a csv file (with properties that I want to fetch), and stored in "/tmp/a.csv"

      2. then I call `blcli_execute Server getBulkServerPropertyValuesAndLogResults /tmp  a.csv` in my Perl code.


      Step 2 results in this error:


      "Command execution failed. com.bladelogic.om.infra.mfw.util.BlException: 1"


      Anyone know what it means?


      I was able to get (1) working. I saw the file being generated and have the contents that I am expecting.


      Then I created just a simple Type 1 NSH script, and I know where the job is going to be run (where /tmp/a.csv is referring to), so I just truncate a.csv down to one line, and just execute the job,


      blcli_execute Server getBulkServerPropertyValuesAndLogResults /tmp  a.csv


      I get the same error. The a.csv is like this,




      As mentioned before, hostA.mydomain.com is from the hostnames passed in, and I use these names to construct the properties of interest and use the blcli / blcli_execute to work against these properties..


      If I empty a.csv, The script would complete successfully! I tried changing hostA.mydomain.com to just hostA in a.csv, and still get the same error.


      Can someone help me please? Thanks.