9 Replies Latest reply on Feb 4, 2016 11:58 AM by Bill Robinson

    Patch analysis job failing for Suse Linux SP2 OS

    Neel Shaha

      Hello Everyone,


      I am running on BSA 8.6.01 on Windows 2008 R2 Server & I have offline patch catalog created for Suse Linux SP2. Patch catalog seems to be working fine & I am able to perform patch analysis, able to create artifacts for most of the customer servers. But there are almost 30 servers on which I am getting error message as "STDERR: cat: rpm-includes.lst: No such file or directory, ERROR::YUM dry run failed." while performing patch analysis.


      I tried to run the patch analysis job in debug mode & went through the logs but I could not trace any error in yum_err.log.

      Attaching the logs for target server along with "rscd.log" here in this discussion.

      Also, only error I can see in the yum_err.log is "IndexError" which don't seems to be any error  as such. Even I went through multiple threads in the community mentioning about error "Yum dry run failed" but could not find any work around or solution to fix this error.

      Also, we recently upgraded Bladelogic from 8.3.02 to 8.6.01 using UPI & target servers have RSCD agent 8.3.02 running seems to be working fine for patch management so as of now there is no plan for agent upgrade to 8.6.01.

      Any suggestion or solution will be helpful in order to resolve this error as there are more than 30 critical customer servers where we are getting same error message.

      Thanks in advance

      Best Regards,

      Neel Shaha