0 Replies Latest reply on Dec 1, 2015 4:40 AM by Chandrakala Mohan

    MyIT 2.2 compatible with BPPM 9.6

    Chandrakala Mohan
      Share This:

      Hello,

       

        

      Bppm 9.6 is compatible for integration with MyIT 2.2

       

       

      Warm Regards,

      Chandrakala