1 2 Previous Next 18 Replies Latest reply on Sep 24, 2015 4:45 AM by V P

    BSA Upgradation Issue

      Hi,

       

      We have installed patch 5 on BSA (Version - 8.5.01) but after doing up-gradation, App service is not getting started.

       

      I have attached logs for your reference.

       

      Note:- There are 2 appserver and we are facing issue on one app server, and on second app server patch has been successfully installed and it is working fine.

       

      Any help would be appreciated.

       

       

      Regards,

        • 1. Re: BSA Upgradation Issue
          Bill Robinson

          can you attach the deployment_upgrade.log ?

          • 2. Re: BSA Upgradation Issue

            Hi Bill,

             

            Deployment_Upgrade log file is absent under NSH/br directory on this app server but it is present on another app server on which patch is successfully applied.

             

            Can you tell me what could be the issue?

             

             

             

            Regards,

            • 3. Re: BSA Upgradation Issue
              Bill Robinson

              Did the upgrade actually run on the problem one ?

              • 4. Re: BSA Upgradation Issue
                Srikanth Kapila

                Can you share the steps performed for deploying the patch on both the application server instances ?

                 

                Regards,

                Srikanth

                • 5. Re: BSA Upgradation Issue

                  Hi Bill,

                   

                  We faced some issue while upgrading app server.

                   

                   

                  Regards,

                  • 6. Re: BSA Upgradation Issue
                    Bill Robinson

                    what issue did you face during the upgrade ? 

                    • 7. Re: BSA Upgradation Issue

                      Hi Bill,

                       

                      I am getting below error

                       

                      [main] [ERROR] [::] [] Error installing to Start: name=bladelogic.service.SSLConnectionService state=Create

                      java.lang.NoClassDefFoundError: Could not initialize class com.bladelogic.security.CryptoFactory

                       

                       

                       

                      Regards,

                      • 8. Re: BSA Upgradation Issue

                        Hi Bill,

                         

                        Also i am getting below error.

                         

                         

                        Error installing to Start: name=bladelogic.service.NshProxyConnectionService state=Create

                        java.lang.ExceptionInInitializerError

                          at com.bladelogic.om.infra.app.rmi.SecureSSLSocketFactoryUtil.getSSLContext(SecureSSLSocketFactoryUtil.java:66)

                          at com.bladelogic.om.infra.app.service.client.ServerSocketFactory.createSocketFactory(ServerSocketFactory.java:177)

                          at com.bladelogic.om.infra.app.service.client.ServerSocketFactory.start(ServerSocketFactory.java:71)

                          at com.bladelogic.om.infra.mfw.fw.Accept.<init>(Accept.java:66)

                         

                         

                         

                        Regards,

                        • 9. Re: BSA Upgradation Issue
                          Bill Robinson

                          you are getting that error on starting the appserver?  what error did you get during the upgrade ? it looks like your upgrade didn't run at all perhaps.

                          • 10. Re: BSA Upgradation Issue

                            Hi Bill,

                             

                            Yes, i am getting that error on starting app server. There was no error during up-gradation also i can't see deployment_upgrade.log file in the NSh/br directory so, I was also thinking of that the up-gradation is failed. Now i tried to re-upgrade same but now the installer is not giving option of upgrade, instead of this, it is showing modify,repair and remove option.

                             

                            Is there any other way to reupgrade the application?

                             

                            or

                             

                            Can we reinstall application? If yes, then what are the configuration files that we need to copy to the new installation directory (After the installation)

                             

                            Note: BSA configured in MAS environment (Multiple App server environment)

                             

                             

                            Any help would be appreciated.

                             

                             

                            Regards,

                            • 11. Re: BSA Upgradation Issue
                              Bill Robinson

                              If there’s no deployment_upgrade then i doubt the upgrade ran correctly.

                               

                              This is a windows 2008+ box?  if so, did you start the installer w/ the ‘run as administrator’ option ?

                               

                              Repair should work here and should re-run the deployment upgrade.

                              • 12. Re: BSA Upgradation Issue

                                Hi Bill,

                                 

                                Yes bill this is win2k8 server. I ran installer with run as administrator and i have selected repair option. During installation there was no error and but i can't see deployment_upgrade.log file under NSH/br. After that when i tried to start the app service it gives the same error.

                                 

                                Is there any other way to resolve that issue?


                                or


                                Can re-installation resolve all that issue? If yes, what are the configuration file that we need to take backup of so data should not get lost?

                                 

                                 

                                Regards,

                                • 13. Re: BSA Upgradation Issue
                                  Bill Robinson

                                  You can try starting a cmd window ‘as administrator’, cd’ing into the NSH/bin directory and then running the deployxmlmigrator.  Then please send the deployments_upgrade.log

                                  • 14. Re: BSA Upgradation Issue

                                    Hi Bill,

                                     

                                    Please find below the deployment_upgrade log file.

                                     

                                    [11 Sep 2015 01:54:35,617] [main] [INFO] [::] [] Starting Model Graph Service...

                                    [11 Sep 2015 01:54:37,286] [main] [INFO] [::] [] Model Graph Service started.

                                    [11 Sep 2015 01:54:37,286] [main] [INFO] [::] [] Registering remote services...

                                    [11 Sep 2015 01:54:37,286] [main] [INFO] [::] [] Remote services registered.

                                    [11 Sep 2015 01:54:37,286] [main] [INFO] [::] [] Performing post-deployment

                                     

                                     

                                    operations...

                                    [11 Sep 2015 01:54:37,286] [main] [INFO] [::] [] Post-deployment operations

                                     

                                     

                                    completed.

                                    [11 Sep 2015 01:54:37,286] [main] [INFO] [::] [] Performing post-startup

                                     

                                     

                                    deployment operations...

                                    [11 Sep 2015 01:54:37,286] [main] [INFO] [::] [] Post-startup deployment

                                     

                                     

                                    operations complete.

                                    [11 Sep 2015 01:54:37,286] [main] [ERROR] [::] [] Failed to update deployments

                                    com.bladelogic.om.infra.mfw.util.BlException: Failed to load deployment _old

                                     

                                     

                                    because directory did not exist.

                                      at com.bladelogic.om.infra.app.util.AppServerUtil.loadDeploymentFile

                                     

                                     

                                    (AppServerUtil.java:302)

                                      at

                                     

                                     

                                    com.bladelogic.om.infra.app.configuration.migration.DeploymentXMLMigrator.init

                                     

                                     

                                    (DeploymentXMLMigrator.java:131)

                                      at

                                     

                                     

                                    com.bladelogic.om.infra.app.configuration.migration.DeploymentXMLMigrator.main

                                     

                                     

                                    (DeploymentXMLMigrator.java:140)

                                    [11 Sep 2015 01:54:37,286] [Thread-0] [INFO] [::] [] Undeploying

                                    [11 Sep 2015 01:54:37,286] [Thread-0] [INFO] [::] [] Stopping Model Graph

                                     

                                     

                                    Service...

                                    [11 Sep 2015 01:54:37,286] [Thread-0] [INFO] [::] [] Model Graph Service

                                     

                                     

                                    stopped.

                                     

                                     

                                    Regards,

                                    1 2 Previous Next