5 Replies Latest reply on Aug 5, 2015 7:07 AM by Bill Robinson

    BSA 8.6 sp1 upgrade issue

    Luciano Spagnuolo

      So for the last couple of weeks I have been performing both types of upgrades from BSA 8.3 sp3 to BSA 86. sp1.  i.e. Unified product installer vs individual component installer.


      I am currently going through the individual component installer for the upgrade and ran across a problem.  My lab environment consists of the following

      1 sql server

      1st app servers (Fileserver, provisioning, single instance type=all)

      2nd app server (2 instances type=all)


      The Database upgrade worked as expected, the first appserver upgrade also worked as expected and I was able to do several job tests to confirm.


      Here is the problem: the upgrade on the 2nd app server was successful but the services fail to start.  Looking at the DB connection first I see that non connect string is set.  At this point I am unable to set the string via blasadmin so I try using the blappconf tool.  The tool launches and no matter what I do I get the error "Invalid database address"  I've tried to manually add the string via the advanced button but get same error.  I am unable to proceed at this point.


      Has anyone come across this and resolved it?


      connection string should be the same as my 1st app server which is jdbc:sqlserver:bsasql:1433;DatabaseName=bladelogic;SelectMothod=cursor


      I suspect that maybe the sql driver is failing to load properly but I have not been able to confirm it.



      Lou Spagnuolo

        • 1. Re: BSA 8.6 sp1 upgrade issue
          Bill Robinson

          What os is the appserver?


          On the 2nd appserver what’s in the NSH/br/deployment_update.log ?


          On the 2nd appserver was _template setup correctly ?


          On the 2nd appserver what’s in NSH/br/deployments/INSTANCENAME/services/asDataSourceService.xml ?

          • 2. Re: BSA 8.6 sp1 upgrade issue
            Luciano Spagnuolo

            OS is RHEL 5.6

            deployment_update,log attached

            _template was setup correctly (the environment was completed tested before the upgrade started)


            NSH/br/deployments/INSTANCENAME/services/asDataSourceService.xml ?

            in the new NSH/br/deployment there are _launcher, _template, _spawner, & default


            in the NSH/br/deployments_bkp

            there are two instances bbsa1-a & bbsa1-b along with _launcher, _pxe, _spawner, & _template


            It looks like not everything got carried over?


            Lou Spagnuolo

            • 3. Re: BSA 8.6 sp1 upgrade issue
              Luciano Spagnuolo

              so I just returned from vacation and thought I would test this again.  I made the a change to the 2nd app server (with multiple instances) and attempted the upgrade again.  This time it worked as expected.  No other changes were made.  Here is what I did.

              1. reverted my virtual servers back to BL 8.3 Sp3 (bbsa, bbsa1, bsasql)

              2. removed the instances on bbsa1 and recreated them with different names

              they were bbsa1-a & bbsa1-b to app1 & app2

              Note: no other changes were made but the instance names

              3. started all app server services, did basic testing to ensure all was functioning

              4. kicked off the unified product installer from the 1st App Server (setup.bin)


              This was the exact same process I used which failed with the instances having a - in the name.  I do not know if this caused the issue but I duplicated the failure a couple of times before renaming the instances and having things work.


              I hope this helps others, for now I will just make a note in my upgrade doc for future reference.


              Lou Spagnuolo

              • 4. Re: BSA 8.6 sp1 upgrade issue
                Mike Reider

                upgrading our dev environment (RHEL6, MSSQL)


                7 of 8 appservers upgraded fine, when running this on 8th appserver, getting this error,


                [root@ulvblgd03 /]# /app/8.6/Disk1/setup.bin -i silent -DOPTIONS_FILE=/tmp/configurator_options.txt


                (Aug 04 2015 01:05:30.726 PM -0400),INFO,setup,

                  LOG EVENT {Description=[OS platform],Detail=[LINUX]}

                (Aug 04 2015 01:05:30.733 PM -0400),INFO,setup,

                  LOG EVENT {Description=[OS architecture],Detail=[x86_64]}

                (Aug 04 2015 01:05:30.767 PM -0400),INFO,setup,

                  LOG EVENT {Description=[Found start of payload],Detail=[145408]}

                (Aug 04 2015 01:05:30.850 PM -0400),INFO,setup,

                  LOG EVENT {Description=[Checking for enough space in temporary directory to extract files]}

                (Aug 04 2015 01:05:30.887 PM -0400),INFO,setup,

                  PROGRESS EVENT {Description=[Unpacking payload entry],Progress=[0],Detail=[1 of 1]}

                (Aug 04 2015 01:05:31.614 PM -0400),INFO,setup,

                  LOG EVENT {Description=[Looking for JVM relative to self],Detail=[/app/8.6/Disk1/files]}

                (Aug 04 2015 01:05:31.806 PM -0400),CONFIG,setup,

                  LOG EVENT {Description=[Got Java version for /app/8.6/Disk1/files/jre/bin/java],Detail=[1.7.0_71]}

                (Aug 04 2015 01:05:31.831 PM -0400),INFO,setup,

                  LOG EVENT {Description=[Found JVM],Detail=[/app/8.6/Disk1/files/jre/bin/java]}

                (Aug 04 2015 01:05:31.935 PM -0400),CONFIG,setup,

                  LOG EVENT {Description=[JVM launcher command],Detail=["/app/8.6/Disk1/files/jre/bin/java" -Xmx512m -classpath "/app/8.6/Disk1/" "-Dsun.java2d.noddraw=true" "-Dswing.volatileImageBufferEnabled=false" "-Djava.logging.properties=/logging.properties" "-Xdebug" "-Xrunjdwp:server=y,transport=dt_socket,address=10333,suspend=n" "-Djava.security.egd=file:/dev/../dev/urandom" -Dbmc.install.LAUNCHER_EXECUTABLE="/app/8.6/Disk1/setup.bin" -jar "/app/8.6/Disk1/setup.jar" "install" -i silent -DOPTIONS_FILE=/tmp/configurator_options.txt]}

                Listening for transport dt_socket at address: 10333

                (Aug 04 2015 01:06:21.895 PM -0400),SEVERE,com.bmc.install.product.bladelogic.standalone.StandaloneCopyGlobalPropertiesIntoDeploymentCommand,

                  THROWABLE EVENT {Description=[Error while copying global.properties file]},

                  Throwable=[java.io.IOException: No such source file: /app/8.6/Disk1/files/data/ulvblgd03/NSH/br/deployments/global.properties







                  java.lang.Thread.run(Unknown Source)]

                (Aug 04 2015 01:06:26.094 PM -0400),SEVERE,com.bmc.install.product.bladelogic.BSAStandaloneStatelessConfiguratorValidationTask,

                  LOG EVENT {Description=[product.bsaoneclickinstall.BSAOneClickInstallInstallerMessages:INSTALLER_INTERNAL_ERROR;CONFIGURATOR_EXECUTION_FAILED[String:STATUS_SUCCESSFUL]],Detail=[An error occurred while retrieving the deployment type from configuration files fetched from infrastructure Application Servers.<br><b>Remediation steps:</b><br>1. Please refer to the installation log file bsainstallupgrade.log located in the host computer's temporary directory to understand the cause of the error.<br>2. If you are not able to determine the problem from the installation log file, please contact BMC support.

                Pre Upgrade execution could not be completed successfully. Database Schema Migration is STATUS_SUCCESSFUL. Application Server upgrade is not attempted.]}

                (Aug 04 2015 01:06:27.109 PM -0400),CONFIG,Command return code,

                  LOG EVENT {Description=[255]}

                (Aug 04 2015 01:06:27.115 PM -0400),INFO,setup,

                  PROGRESS EVENT {Description=[Unpacked payload entry],Progress=[100],Detail=[1 of 1]}

                (Aug 04 2015 01:06:27.125 PM -0400),INFO,setup,

                  LOG EVENT {Description=[Extracted payload entry count],Detail=[1]}

                I checked the global.properties, its in /opt/bmc/bladelogic/NSH/br/deployments/ dir and looks exactly same as other servers

                • 5. Re: BSA 8.6 sp1 upgrade issue
                  Bill Robinson

                  i think i've seen that error when something was messed up w/ the deployments, can you check that _template, _pxe, etc are all using the correct db info ?