2 Replies Latest reply on Jul 16, 2015 7:32 AM by Atul Matkar

    BL Package error

    Atul Matkar

      In my BL package i am copying 3 files on target and in external command i am doing below code.

      cd c:\tmp\ClientMSI

      msiexec.exe /i C:\tmp\ClientMSI\BESClientMSI.msi /T=1033 /qn

      copy c:\tmp\ClientMSI\actionsite.afxm c:\PROGRA~2\BIGFIX~1\BESCLI~1\

       

      I also tried with

      copy c:\tmp\ClientMSI\actionsite.afxm c:\Program Files (x86)\BigFix Enterprise\BES Client\

       

      Error

      07/16/15 19:24:55.669 INFO     bldeploy - [4][Execution] Processing asset EXTERNALCMD

      07/16/15 19:24:55.669 INFO     bldeploy - [4][Execution] Executing command: "cd c:\tmp\ClientMSI

      msiexec.exe /i C:\tmp\ClientMSI\BESClientMSI.msi /T=1033 /qn

      copy c:\tmp\ClientMSI\actionsite.afxm c:\PROGRA~2\BIGFIX~1\BESCLI~1\"

      07/16/15 19:24:55.669 DEBUG    bldeploy - [4][Execution] chdir to PkgDir: 'C:\tmp\stage\66a7861e5d4f3493ac06e179b94907dd\'

      07/16/15 19:24:55.669 DEBUG    bldeploy - [4][Execution] exeFullPath = (null), CmdLine = "C:\tmp\stage\66a7861e5d4f3493ac06e179b94907dd\bldeploycmd.4.bat", workingDir = NULL

      07/16/15 19:25:06.280 INFO     bldeploy - [4][Execution] [stdout: 4]        0 file(s) copied.

      07/16/15 19:25:06.280 WARN     bldeploy - [4][Execution] [stderr: 4] The system cannot find the path specified.

       

      07/16/15 19:32:56.219 INFO     bldeploy - [4][Execution] Processing asset EXTERNALCMD

      07/16/15 19:32:56.219 INFO     bldeploy - [4][Execution] Executing command: "cd c:\tmp\ClientMSI

      msiexec.exe /i C:\tmp\ClientMSI\BESClientMSI.msi /T=1033 /qn

      copy c:\tmp\ClientMSI\actionsite.afxm c:\Program Files (x86)\BigFix Enterprise\BES Client\"

      07/16/15 19:32:56.219 DEBUG    bldeploy - [4][Execution] chdir to PkgDir: 'C:\tmp\stage\66a7861e5d4f3493ac06e179b94907dd\'

      07/16/15 19:32:56.235 DEBUG    bldeploy - [4][Execution] exeFullPath = (null), CmdLine = "C:\tmp\stage\66a7861e5d4f3493ac06e179b94907dd\bldeploycmd.4.bat", workingDir = NULL

      07/16/15 19:33:03.001 INFO     bldeploy - [4][Execution] [stdout: 4] The syntax of the command is incorrect.

      07/16/15 19:33:03.001 DEBUG    bldeploy - [4][Execution] In RunProcess: exitCode = 1

      07/16/15 19:33:03.001 ERROR    bldeploy - [4][Execution] Command returned non-zero exit code: 1