6 Replies Latest reply on Sep 28, 2015 2:11 AM by Avikal Jain

    BladeLogic 8.6 SP1 Installation with Domain Accounts

    Jared Murrell

      So, I started the installation of BSA 8.6 SP1 on a Windows server and I noticed two things:


      1) Domain accounts are not supported by the installer

      2) Non-default RSCD ports are not supported. The installer fails to validate the File Server if it is not running on port 4750


      When launching the installer with a domain account it fails at the very beginning with the following error:


      Execution of the command "C:\Windows\System32\chcp.com 437&C:\Windows\System32\net.exe user <username>" failed. To determine why the command failed, manually execute the command "C:\Windows\System32\chcp.com 437&C:\Windows\System32\net.exe user <username>".


      So then I opened a CMD prompt and ran the command:


      C:\>chcp 437 & net user <username>

      Active code page: 437

      The user name could not be found.


      More help is available by typing NET HELPMSG 2221.


      Since my user account is on the domain, this installer can't validate the username. I can see this as being a significant issue in some environments, but there's a work-around if you have access to the local admin account. Simply run the following command (you'll need the password to the local account)


      PS C:\> cd "<install_dir>"

      PS D:\BSA86SP1> runas /user:<local_username> .\setup.exe


      You should get the following message and the install will go through successfully.


      Enter the password for <local_username>:

      Attempting to start .\setup.exe as user "<hostname>\<local_username>" ...