8 Replies Latest reply on Jun 1, 2015 7:00 AM by Bill Robinson

    Email sendMailWith Attachment reports error

    Rajesh Kumar

      Hi Team,


      I tried to use the blcli command (Email sendMailWithAttachment) to send email. However, I get error that the file not found even if the file that I wanted to send exist in the specified location.


      Here is the screenshot.


      The file that I wanted to send is "xrxdallin001.txt" and it is present in the location "//XRXDALLIN001/tmp/Appserverdetails". The command that I used is blcli_execute Email sendMailWithAttachment "$from" "$to" "Appserver Status" "$body" /tmp/Appserverdetails xrxdallin001.txt.

      I get the error "Command execution failed. com.bladelogic.om.infra.mfw.util.BlException: File provided does not exist"


      I tried to add "" to the File location, File name etc and tried the other combinations. It simply fails with the same error. All these commands are tried in the NSH console invoked by Right click the Server in the BSA console -> Run Custom Command -> NSH Here.


      Any suggestions on this would be helpful.


      Thanks in advance.