1 2 Previous Next 28 Replies Latest reply on Apr 26, 2015 11:19 PM by Raja Mohan

    BSA Provisioning Error : Could not boot tftp :  pxelinux.0

    Orwin Lopes

      Hi Experts,

       

      I am trying to provision RHEL in my environment using below settings. I am getting error Error: Could not boot tftp : tftp://192.168.160.4//pxelinux//pxelinux.0 : Error 0x00000001. Initially thought the permissions were not given ,but still no progress on this one even after giving the permissions.

       

        • 1. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
          Raja Mohan

          look at the file /APS/tftproot/X86PC/pxelinux/pxelinux.cfg/C0A8A08E and see what you have on it. Your kickstart file to boot image is probably set wrong. That is usually configured in your system package as URL or Server

          • 2. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
            Bill Robinson

            Raja Mohan you need to rtm on pxe booting because what you said makes no sense: Understanding PXE Booting and Kickstart Technology is one place you can look.

             

            so in the tftp log i see:

            [22 Apr 2015 15:20:16,800] [Thread-198004] [INFO] Completed read request from /192.168.160.142. File name : /APS/tftproot/X86PC/pxelinux/pxelinux.0

            [22 Apr 2015 15:20:16,853] [Thread-0] [INFO] Received read request from /192.168.160.142

             

            so it seems to be reading the file.  can you manually pull the file w/ a tftp client ?  and where did you get it from?  the bsa install or somewhere else ?

             

            your tftp root on the file system is /APS/tftproot ? and that's what set in the blade db or the pxe/tftp conf files ?

            and what else is in that directory and the sub-directories ?

             

            what's in the pxe.log when this happens ?  you are not handing out dhcp options 66 and 67 on the dhcp server right? you are letting the bsa pxe server do that ?

             

            this looks like kvm/libvirt - so is that ipxe or gpxe ?

            • 3. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
              Orwin Lopes

              Hi Raja,

               

              i changed my kickstart to proper location. Still facing the same issue.

              • 4. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                Raja Mohan

                Bill Robinson I am not sure what you are attempting to infer at and hope it is not an attempt to dissuade people from participating in the forum, but based on the logs he has posted on this thread  pxe process is successful until the pxeboot.msg. He is failing to receive the kernel (vmlinuz) and the initial ram disk (initrd) with pointers to kickstart file.

                 

                As far as I can tell, in BSA this pxe configuration file is dynamically auto-generated/populated from the kickstart entries on the system package. At this point, the boot fails and switches to local boot. At the lack of understanding his setup or environment, my attempt is to verify the contents of auto generated pxe configuration file.

                • 5. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                  Raja Mohan

                  Orwin Lopes as Bill had mentioned, have you copied the Linux kernel and initrd.img to the correct location under pxelinux? This is the information you specify under "Provisioning Manager Configurations" -> "System Package Types" tab. The options you are looking for is "Boot kernel file name" and "Boot image file name". Validate the path for these files.

                  • 6. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                    Orwin Lopes

                    Hi Bill,

                     

                    In Blade Db it is set to same. Actually my provisioning for Win 2008 R2 Server is sucessfull on the same App Server.

                    i am trying to provision on the same App Server on KVM. its gPXE

                    Please find attached PXE logs.

                     

                    23 Apr 2015 11:43:24,265] [Thread-4222] [INFO] [::] [] RPacketProcessor Thread id= 4883 started

                     

                     

                    [23 Apr 2015 11:43:24,267] [Thread-4222] [INFO] [::] [] Received packet is from a gPXE

                     

                     

                    [23 Apr 2015 11:43:24,267] [Thread-4222] [INFO] [::] [] Packet type is DHCP Discover setting up DHCP Offer packet for reply

                     

                     

                    [23 Apr 2015 11:43:24,267] [Thread-4222] [INFO] [::] [] Replying to /255.255.255.255:68

                     

                     

                    [23 Apr 2015 11:43:24,267] [Thread-4222] [INFO] [::] [] RPacketProcessor Thread id= 4883 Finished

                     

                     

                    [23 Apr 2015 11:43:24,267] [Thread-9] [INFO] [::] [] (U)FD:258

                     

                     

                    [23 Apr 2015 11:43:24,267] [Thread-9] [INFO] [::] [] (M)FD:259

                     

                     

                    [23 Apr 2015 11:43:24,267] [Thread-9] [INFO] [::] [] (M)FD:264

                     

                     

                    [23 Apr 2015 11:43:25,000] [Thread-9] [INFO] [::] [] activity fd index:2

                     

                     

                    [23 Apr 2015 11:43:25,001] [Thread-9] [INFO] [::] [] DatagramSocket received

                     

                     

                    [23 Apr 2015 11:43:25,001] [Thread-4223] [INFO] [::] [] RPacketProcessor Thread id= 4884 started

                     

                     

                    [23 Apr 2015 11:43:25,003] [Thread-4223] [INFO] [::] [] Received packet is from a gPXE

                     

                     

                    [23 Apr 2015 11:43:25,003] [Thread-4223] [INFO] [::] [] Packet type is DHCP Request setting up DHCP ACK packet for reply

                     

                     

                    [23 Apr 2015 11:43:25,003] [Thread-4223] [INFO] [::] [] Replying to /255.255.255.255:68

                     

                     

                    [23 Apr 2015 11:43:25,003] [Thread-4223] [INFO] [::] [] RPacketProcessor Thread id= 4884 Finished

                     

                     

                    [23 Apr 2015 11:43:25,003] [Thread-9] [INFO] [::] [] (U)FD:258

                     

                     

                    [23 Apr 2015 11:43:25,003] [Thread-9] [INFO] [::] [] (M)FD:259

                     

                     

                    [23 Apr 2015 11:43:25,003] [Thread-9] [INFO] [::] [] (M)FD:264

                     

                     

                    [23 Apr 2015 11:43:25,456] [Thread-9] [INFO] [::] [] activity fd index:1

                     

                     

                    [23 Apr 2015 11:43:25,457] [Thread-9] [INFO] [::] [] DatagramSocket received

                     

                     

                    [23 Apr 2015 11:43:25,457] [Thread-4224] [INFO] [::] [] RPacketProcessor Thread id= 4885 started

                     

                     

                    [23 Apr 2015 11:43:25,459] [Thread-4224] [INFO] [::] [] Received packet is from a gPXE

                     

                     

                    [23 Apr 2015 11:43:25,459] [Thread-4224] [INFO] [::] [] It is a boot server request packet from /192.168.160.143:68

                     

                     

                    [23 Apr 2015 11:43:25,459] [Thread-4224] [INFO] [::] [] Will create light weight prov device object

                     

                     

                    [23 Apr 2015 11:43:25,460] [Thread-4224] [INFO] [::] [] Provision device 52-54-00-D6-87-F1 exists in the system

                     

                     

                    [23 Apr 2015 11:43:25,460] [Thread-4224] [INFO] [::] [] Provision device object active

                     

                     

                    [23 Apr 2015 11:43:25,460] [Thread-4224] [INFO] [::] [] IP address of the device :192.168.160.143 Architecture is x64

                     

                     

                    [23 Apr 2015 11:43:25,460] [Thread-4224] [INFO] [::] [] Packet type is DHCP Request setting up DHCP ACK packet for reply

                     

                     

                    [23 Apr 2015 11:43:25,460] [Thread-4224] [INFO] [::] [] makeBootMenu : type 2

                     

                     

                    [23 Apr 2015 11:43:25,462] [Thread-4224] [INFO] [::] [] State of the device before PXE configuration file:Make Run Once

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-4224] [INFO] [::] [] State of the device after PXE boot :Phase 1 OS Install

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-4224] [INFO] [::] []  Device State set to Phase 2 OS Install

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-4224] [INFO] [::] [] ProvDeviceCreator : scheduling for updation 52-54-00-D6-87-F1

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-4224] [INFO] [::] [] Replying to /192.168.160.143:68

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-4224] [INFO] [::] [] RPacketProcessor Thread id= 4885 Finished

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-9] [INFO] [::] [] (U)FD:258

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-9] [INFO] [::] [] (M)FD:259

                     

                     

                    [23 Apr 2015 11:43:25,463] [Thread-9] [INFO] [::] [] (M)FD:264

                     

                     

                    [23 Apr 2015 11:43:29,971] [Thread-10] [INFO] [::] [] ProvDeviceCreator : updated device 52-54-00-D6-87-F1

                     

                     

                    [23 Apr 2015 11:43:33,585] [Thread-9] [INFO] [::] [] activity fd index:2

                     

                     

                    [23 Apr 2015 11:43:33,585] [Thread-9] [INFO] [::] [] DatagramSocket received

                     

                     

                    [23 Apr 2015 11:43:33,586] [Thread-4226] [INFO] [::] [] RPacketProcessor Thread id= 4887 started

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-4226] [INFO] [::] [] Received packet is from a gPXE

                     

                    [23 Apr 2015 11:43:33,588] [Thread-4226] [INFO] [::] [] Packet type is DHCP Discover setting up DHCP Offer packet for reply

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-4226] [INFO] [::] [] Replying to /255.255.255.255:68

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-4226] [INFO] [::] [] RPacketProcessor Thread id= 4887 Finished

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-9] [INFO] [::] [] (U)FD:258

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-9] [INFO] [::] [] (M)FD:259

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-9] [INFO] [::] [] (M)FD:264

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-9] [INFO] [::] [] activity fd index:2

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-9] [INFO] [::] [] DatagramSocket received

                     

                     

                    [23 Apr 2015 11:43:33,588] [Thread-4227] [INFO] [::] [] RPacketProcessor Thread id= 4888 started

                     

                     

                    [23 Apr 2015 11:43:33,590] [Thread-4227] [INFO] [::] [] Received packet is from a gPXE

                     

                     

                    [23 Apr 2015 11:43:33,590] [Thread-4227] [INFO] [::] [] Packet type is DHCP Request setting up DHCP ACK packet for reply

                     

                     

                    [23 Apr 2015 11:43:33,590] [Thread-4227] [INFO] [::] [] Replying to /255.255.255.255:68

                     

                     

                    [23 Apr 2015 11:43:33,590] [Thread-4227] [INFO] [::] [] RPacketProcessor Thread id= 4888 Finished

                     

                     

                    [23 Apr 2015 11:43:33,590] [Thread-9] [INFO] [::] [] (U)FD:258

                     

                     

                    [23 Apr 2015 11:43:33,590] [Thread-9] [INFO] [::] [] (M)FD:259

                     

                     

                    [23 Apr 2015 11:43:33,590] [Thread-9] [INFO] [::] [] (M)FD:264

                     

                     

                    [23 Apr 2015 11:43:33,956] [Thread-9] [INFO] [::] [] activity fd index:1

                     

                     

                    [23 Apr 2015 11:43:33,956] [Thread-9] [INFO] [::] [] DatagramSocket received

                     

                     

                    [23 Apr 2015 11:43:33,957] [Thread-4228] [INFO] [::] [] RPacketProcessor Thread id= 4889 started

                     

                     

                    [23 Apr 2015 11:43:33,959] [Thread-4228] [INFO] [::] [] Received packet is from a gPXE

                     

                    [23 Apr 2015 11:43:33,959] [Thread-4228] [INFO] [::] [] It is a boot server request packet from /192.168.160.143:68

                     

                     

                    [23 Apr 2015 11:43:33,959] [Thread-4228] [INFO] [::] [] Will create light weight prov device object

                     

                     

                    [23 Apr 2015 11:43:33,960] [Thread-4228] [INFO] [::] [] Provision device 52-54-00-D6-87-F1 exists in the system

                     

                     

                    [23 Apr 2015 11:43:33,960] [Thread-4228] [INFO] [::] [] Provision device object active

                     

                     

                    [23 Apr 2015 11:43:33,960] [Thread-4228] [INFO] [::] [] IP address of the device :192.168.160.143 Architecture is x64

                     

                     

                    [23 Apr 2015 11:43:33,960] [Thread-4228] [INFO] [::] [] Packet type is DHCP Request setting up DHCP ACK packet for reply

                     

                     

                    [23 Apr 2015 11:43:33,960] [Thread-4228] [INFO] [::] [] makeBootMenu : type 2

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-4228] [INFO] [::] [] State of the device before PXE configuration file:Phase 2 OS Install

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-4228] [INFO] [::] [] State of the device after PXE boot :Provisioned

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-4228] [INFO] [::] [] Device instructed to local boot

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-4228] [INFO] [::] [] Replying to /192.168.160.143:68

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-4228] [INFO] [::] [] RPacketProcessor Thread id= 4889 Finished

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-9] [INFO] [::] [] (U)FD:258

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-9] [INFO] [::] [] (M)FD:259

                     

                     

                    [23 Apr 2015 11:43:33,963] [Thread-9] [INFO] [::] [] (M)FD:264

                     

                     

                    [23 Apr 2015 11:43:36,846] [Thread-8] [INFO] [::] [] [PxeServerMonitor]: Current Active RPacketProcessor Threads:0

                     

                     

                    [23 Apr 2015 11:43:36,846] [Thread-8] [INFO] [::] [] [PxeServerMonitor]: Thread ID: 26|| Thread Name: Thread-9|| Thread Description: PxeNet Thread to read DHCP packets|| Alive status is:true

                     

                     

                    [23 Apr 2015 11:43:36,846] [Thread-8] [INFO] [::] [] [PxeServerMonitor]: Thread ID: 27|| Thread Name: Thread-10|| Thread Description: ProvDeviceCreator Thread Adds New DEVICES|| Alive status is:true

                     

                     

                    [23 Apr 2015 11:43:36,847] [Thread-8] [INFO] [::] [] [PxeServerMonitor]: [Total JVM Memory (B)675,807,232 - Free JVM Memory (B)469,344,544] = Used JVM Memory (B)206,462,688

                     

                     

                    [23 Apr 2015 11:43:48,196] [Scheduled-System-Tasks-Thread-7] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 675807232,Free JVM (B): 469344544,Used JVM (B): 206462688,VSize (B): 5694926848,RSS (B): 625070080

                     

                     

                    [23 Apr 2015 11:43:51,847] [Thread-8] [INFO] [::] [] [PxeServerMonitor]: Current Active RPacketProcessor Threads:0

                     

                     

                     

                    Bill Robinson  @Raja Mohan

                    • 7. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                      Orwin Lopes

                      Hi Bill, Raja,

                       

                      i did changed & corrected the directories under system packages. After this i am getting this screen & then it again boot ups & give the previous screen.

                       

                       

                      Bill Robinson @Raja Mohan

                      • 8. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                        Raja Mohan

                        Orwin Lopes

                        Your first screen shot is actually a good sign :-), meaning you booted fine from the initial pxe process but you are missing the install files. Now on the kickstart entries what do you have for install location? url or nfs?

                        • 9. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                          Abhishek Tundalwar

                          Hi Orwin,

                           

                          It seems the Bare metal machine is not able to boot from network as it is not able to fine the path:

                          tftp://192.168.160.4///X86PC//pxe//pxelinux//pxelinux.0

                           

                          can you please make it like below and try also show me the tftproot directory and its settings

                           

                          tftp://192.168.160.4/X86PC/pxe/pxelinux/pxelinux.0


                          Regards,

                          Abhi

                          • 10. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                            Abhishek Tundalwar

                            Can you please show us the provisiong manager configuration of TFTP and PXE,

                             

                            also mention the path of tftproot given while installing PXE.

                             

                            Regards,

                            Abhi

                            • 11. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                              Abhishek Tundalwar

                              Also in Last screenshot, machine is trying to boot from local disk I thing it should be from network, can you verify the bios setting and change the boot priority to network from local disk.

                               

                              Regards,

                              Abhi

                              • 12. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                                Orwin Lopes

                                Hi Abhi,

                                 

                                It is already set to boot from network.The second screenshot is when the netowrk boot fails it tries to boot from local disk.

                                • 13. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                                  Orwin Lopes

                                  Hi Raja,

                                   

                                  Glad to know that ! The kick start entry is set to correct Url .

                                   

                                  • 14. Re: BSA Provisioning Error : Could not boot tftp :  pxelinux.0
                                    Raja Mohan

                                    what is the content of this file /tftproot/X86PC/pxelinux/pxelinux.cfg/C0A8A08F ? This is the pxe configuration file which will have the boot parameters including "ks=http://(resolved ??DATA_STORE_IP??)/datastore/01-52-54-00-d6-87-f1. If that information is correct, then check the content of that file by browsing it @ http://(resolved ??DATA_STORE_IP??)/datastore/01-52-54-00-d6-87-f1

                                    1 of 1 people found this helpful
                                    1 2 Previous Next