2 Replies Latest reply on Apr 1, 2015 10:28 PM by Brendan Murray


    Brendan Murray
      Share This:

      I have mentioned this before, but I feel the need to bring it up again. I would like to see us call things by the simplest, most sensible names to avoid confusing users. To that end, I believe we should rename the built-in fields COLLECTOR_NAME and COLLECTOR. In my opinion, they are misnamed and unnecessarily confusing. The COLLECTOR_NAME is the user-defined name of the data collector, Therefore it should be called simply "COLLECTOR". The "_NAME" suffix is superfluous. Why do we use it here and not with all other fields? If we are going to be consistent, we should append the "_NAME" suffix to all other fields since all fields are data elements with names. So the fields in the screen shot below would be called "HOST_NAME", "DATA_PATTERN_NAME" AND "severity_NAME". Yes, it would be ugly and ridiculous, but it would at least be consistent.

      Collector Name vs. Collector.png

      If the reason we add the "_NAME" suffix to the COLLECTOR_NAME field is to distinguish it from the COLLECTOR field, I would argue that we are just compounding a mistake by doing this. The COLLECTOR field is misnamed. What we call the "COLLECTOR" is actually the data source, whether it be a file, a Windows Event log or Syslog receiver. We should therefore call it the DATA_SOURCE or simply SOURCE.