6 Replies Latest reply on Mar 27, 2015 9:39 AM by Bill Robinson

    'null' becoming "" on parameter update

    Narahari Lakshminarayana

      Friends:

       

      Thank you for taking your valuable time to read this.  Very much appreciated.

       

      I am trying to update the parameter on a NHSScriptJob.  I tried to set the keyword null but it is getting translated as "".

      The following  is the code

      jobFolder="/test/Narahari

      jobName="updateRevVerVal"

      paramIndex="36"

      paramValue="null"

      blcli_execute NSHScriptJob addNSHScriptParameterValueByGroupAndName "$jobFolder" "$jobName" "$paramIndex" "$paramValue"

      blcli_storeenv dbKey

      blcli_execute Job findByDBKey "$dbKey"

      blcli_execute Job update

       

      What is happening is that the parameter of "updateRevVerVal" is being  set to "" instead of the key word null.

       

      I tried 'null', but then it puts 'null' instead of null aka with single quotes.

      I tried "\"null\"" but then it puts "null" instead of null, aka with double quotes

       

      So how to make the string null come into the parameter value ?

       

      Any ideas/inputs will help.

       

      Regards.

      -Narahari