1 Reply Latest reply on Jul 21, 2015 2:53 PM by Sylvie Boucher

    DMT8.1: Transactional Contract Load & Possible Bugs?

    Bjorn Calabuig
      Share This:

      Hi List,

      My 5 cents in order to improve/correct some things I believe someone has missed.


      As far as now, here are some problems I've detected with this load.

       

      1. Unable to load Master Contracts (not solved)

      If you try to load Master Certificates, two problems related to this:

       

      a) Master Certificate ID isn't present on spreadsheet (please take a look below, Point 3)

               Seems to be solved, but I'm not able to test it because there's another problem.... 1273; (b)


      b) Getting all the time Error Code 1273;

      The Master Certificate Identifier specified either does not exist or does not have an identical Product Tier, License Type and Contract for this license certificate.


        Things I've tried right now:

        - a load with just one SLC and one LC (this one as No Group)

                Both SLC ans LC are created and appear related (License Detail tab)

       

        - a load with just one SLC and one LC (this one as Master Certificate)

                Validation fails but both SLC and LC are created but NOT related


        - a load with just one SLC and  3 LCs (one as Master Certificate, the other two as Attached to Group)

                Error 1273!

      IM001.jpg


      2. Unable to load Never Ending SLCs (solved)

      OOTB, it was not possible to load Never Ending SLCs due to fact that this two filters seem to have a bug:

       

      CTR:DCN:ValidateExpirationDateReq4Lea_Mai_Sof_Sup_SetErr

      ('Expiration Date' = $NULL$) AND (('ContractType' = "Lease") OR ('ContractType' = "Maintenance") OR ('ContractType' = "Support") OR ('ContractType' = "Warranty") OR ('ContractType' = $NULL$) OR  (('ContractType' = "Software License") AND ('Type' = "Never ending")))

       

      CTR:DCN:ValidateNotificationDateReq4Lea_Mai_Sup_War_SetErr

      ('Notification Date' = $NULL$) AND (('ContractType' = "Lease") OR ('ContractType' = "Maintenance") OR ('ContractType' = "Support") OR ('ContractType' = "Warranty") OR ('ContractType' = $NULL$) OR (('ContractType' = "Software License") AND ('Type' = "Never ending")))


      Just overlay them and change this:

      AND ('Type' = "Never ending") -> AND ('Type' != "Never ending")

       

      3. Unable to load Cost per Asset (solved)

      The column isn't present on AST_LoadLicenseCertificates tab.

      To be able to load that info:

      • Add the column "Cost per asset" to spreadsheet (AST_LoadLicenseCertificates tab)
      • Modify transformation "Transactional_Contract" including the field
      • Copy the "Cost per Asset" field from AST:LicenseCertificates and past it on AST:LoadLicenseCertificates form
      • Save changes but giving the new field a new name and a new field id
      • Create a new Filter, let's call it "F01:AST:LLC:CreateLicenseCert" as a copy of "AST:LLC:CreateLicenseCert"
        • Respect everything except:
          • Push Fields: Uncheck Matching ids
          • Enter the mapping for the new field between the forms

       

      4. Where to enter #licenses purchased, deployed and breaching levels

      After digging a little bit, finally the answer is to use Compliance Ans 01 - Compliance Ans 04 fields (if you use License Type "Per Copy")

       

      Compliance Ans 01: #licenses purchased

      Compliance Ans 02: #licenses deployed

      Compliance Ans 03: #licenses breaching level #1

      Compliance Ans 04: #licenses breaching level #2

       

      Hope this helps.

      Any help would be appreciated in order to solve Point 1.

       

      Kind Regards,

      Björn.

        • 1. Re: DMT8.1: Transactional Contract Load & Possible Bugs?

          Good day Björn,  we are encountering also problems loading license certificates. 

           

          Here are the two symptoms :

          1) Products item associated to a company (instead "- Global -") in the Product Catalog are not recognized


          We have associated all product catalog items to a specific company.  When we run the DMT job, we have the following message :

           

          Error_Code : 11005;11006;11007;11008;11009;11010;

          Error_Message :

          Invalid Manufacturer; Invalid Product Name

          This data may not be found in the Product Catalog in valid state, with the correct Company/Module relationship. If loaded in an earlier step, this validation may have failed.; Invalid Market Version; Invalid Product Categorization Tier 1

          This data may not be found in the Product Catalog in valid state, with the correct Company/Module relationship. If loaded in an earlier step, this validation may have failed.; Invalid Product Categorization Tier 2

          This data may not be found in the Product Catalog in valid state, with the correct Company/Module relationship. If loaded in an earlier step, this validation may have failed.; Invalid Product Categorization Tier 3

          This data may not be found in the Product Catalog in valid state, with the correct Company/Module relationship. If loaded in an earlier step, this validation may have failed.

           

          When we use a product that is associated to - Global - the DMT completes normally.

           

          Have you encountered this problem ? 


          2) Confusion between Model_Version and Market_Version in the

          In the template we have to enter the Model_Version corresponding to the Product Catalog item.  When we run the DMT job, we have the following message : Error_Code : 11007 and Error_Message : Invalid Market Version.

           

           

           

          We did another test using the Market_Version and the DMT job complete successfully.  This situation is not valid for us because we need to know and use the model version of the certificate we have bought and we use the market version to run the Compliance job.

           

          After investigation using Developer Studio, we realized that the Model_Version is linked to the form

          bug - certificat.gif

          bug - certificat 2.gif

           

           

           

           

          Why is it looking for Market Version, it should look for Model Version?

           

           

          Have you already encountered these 2 situations ?

           

          Your feedback will be appreciate very much!

           

          Cordially !

           

          Sylvie