6 Replies Latest reply on Mar 17, 2015 9:53 AM by Mike Brennan

    Bladelogic file content Audit job - erroneous results

    Mike Brennan

      Hey all,


      So I have a simple shell script file that should be the same on each of my servers. 

      I added a golden copy of it to the depot.  I then created a package containing it and this allowed me to have a deploy job for the file.  I have executed this against my servers and I can see the file is in the correct directory with the correct contents.


      At this point everything is good.


      Moving forwards I wanted a way to make sure this file doesnt change without my knowledge.


      Therefore I created a component template to identify all the servers this file was on.

      I created a discovery job which ran without any issues and created all the relevant components.

      Using this I created an audit job.


      This is where the issues begin.  When I run this audit job I get very mixed results.  Normally half or more of the servers report that they match my master server.  The rest report differences which simply do not make sense or exist if you check manually.


      An example of this:

      Endpoint          0 Changes     2 Extra      2 Missing


      Master          Endpoint

      etit               exit

      etit               exit


      As you can see it seems to garble the word exit.


      I thought the issue may be something to do with formatting so I added a dos2unix external command to the deploy package.
      Still no joy.
      Each time I run the audit the servers reported as not in line with the master are different?!

      Any ideas?


      Thanks for any help in advance