6 Replies Latest reply on Mar 26, 2015 1:26 PM by Steve Cupp

    Troubleshooting Advanced Repeaters

    Steve Cupp

      I have two Advanced repeaters that will not allow any deploy job that is set to "Stage indirect (using repeaters)" to get past the Stage phase. If I use "Stage direct" in the deploy job it completes successfully. I have checked these Advanced Repeaters in Infrastructure management and I can update the status and can also perform all the Repeater cache functions successfully.

       

      Does anyone have any idea what may be happening here or at least help me know where to look further to find what causing this problem?

       

      Thank you as always

       

      Below is a sample of the status.

       

      Name:FR01APTBMCP01

      Description:Fresno PXE/Repeater

      Host:FR01APTBMCP01.fr.trinity-health.org

      Staging directory:/C/BSA_Staging

      Advanced Repeater:enabled

      Advanced Repeater root directory:/C/Program Files (x86)/BMC Software/Bladelogic/AdvancedRepeater/Tuner/

      Automation Principal:null

      Cache low watermark:75

      Cache max size (MB):30720

      Listener port:8082

      RPC port:7717

      Simultaneous connections:1024

      Enable bandwidth management:true

      Use no more than (Kbps):84500

      Staging mount point:/C

      Total staging (KB):104855548

      Used staging (KB):60693372

      Free staging (KB):44162176

       

      Status for Proxy (Version 7.5) on 10.250.216.12: Running

       

      Server information:

          Port:8082

          Root Directory:C:\BSA_Staging\.marimba\proxyroot

          Logs Directory:C:\BSA_Staging\.marimba\proxyroot\logs

       

      Cache information:

          Current Cache Size:23 MB

          Maximum Cache Size:30720 MB

          Low water mark:75 %

       

      Performance information:

       

          Maximum concurrent connections:1024

          Transfer buffer size:8192

        • 1. Re: Troubleshooting Advanced Repeaters
          Bill Robinson

          what kind of deploy jobs are these ?  are the payloads on the file server or on a nsh url ?

           

           

          are there errors in the job run log or appserver log when you use the ars ?

          • 2. Re: Troubleshooting Advanced Repeaters
            Steve Cupp

            They are deploy jobs for a BLpackages. The content is on the File server, in fact one of the blpackages doesn't have any content, it simply executes an existing windows batch file on the target via external command.


            The job run never gets past the Stage phase, the GUI shows this:


            Please forgive, but I don't know what "ars" is.

            The appserver.log has stuff like this at the time I run the job:

             

            [19 Feb 2015 19:40:32,427] [Client-Connections-Thread-7] [INFO] [cupps@XXXXX:BLAdmins:10.200.102.64] [Client] Executing <Execute Against> Action against group targets:  for job: /Development/Steve/General_Jobs_Workspace/Push_A_File_Test

            [19 Feb 2015 19:41:17,731] [Scheduled-System-Tasks-Thread-2] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 294649856,Free JVM (B): 88670040,Used JVM (B): 205979816,VSize (B): 1042550784,RSS (B): 733028352,Used File Descriptors: 3427,Used Work Item Threads: 0/100,Used Client Connections: 5/200,DB Client-Connection-Pool: 2/2/0/100,DB Job-Connection-Pool: 3/3/0/100,DB General-Connection-Pool: 2/2/0/100

            [19 Feb 2015 19:42:17,731] [Scheduled-System-Tasks-Thread-5] [INFO] [System:System:] [Memory Monitor] Total JVM (B): 294649856,Free JVM (B): 73993872,Used JVM (B): 220655984,VSize (B): 1042636800,RSS (B): 733077504,Used File Descriptors: 3420,Used Work Item Threads: 0/100,Used Client Connections: 5/200,DB Client-Connection-Pool: 2/2/0/100,DB Job-Connection-Pool: 3/3/0/100,DB General-Connection-Pool: 2/2/0/100

            • 3. Re: Troubleshooting Advanced Repeaters
              Bill Robinson

              ARS = Advanced Repeater Server

               

              so does it hang at 'stage' ?  or eventually fail ?

               

              is there a bldeploy log created on the target?  if so can you attach that - and there should be a lot for the ars -Isaac Matta might have some ideas too

              • 4. Re: Re: Troubleshooting Advanced Repeaters
                Steve Cupp

                It appears that the job just hangs at Stage and never fails, but I haven't waited more than a few hours. The attached logs are from one of the targets in the time period when the job was deploying and hung at stage. I didn't see any indication of activity after the simulate phase ran.

                • 5. Re: Troubleshooting Advanced Repeaters
                  Bill Robinson

                  so the issue here was the repeater wasn’t running ?  and then there were some issues w/ the agent installer package type replicating?

                  • 6. Re: Troubleshooting Advanced Repeaters
                    Steve Cupp

                    Just to close this thread out, after working with support it was determined that the issue we were seeing with our advanced repeaters not responding was not related to the repeaters at all but with our Advanced File server and it being overwhelmed by our Unified agent installer job. The exact reason why has not been determined, we have simply stopped using that job and plan to rebuild it once we update to 8.5 SP5.