2 Replies Latest reply on Feb 9, 2015 2:03 PM by Steffen Kreis

    Issue with Compliance export in 8.6

    Steffen Kreis

      Hi,

       

      can somebody do me a favour and try to export a certain Compliance report in 8.6 using blcli  ?

       

      blcli_execute ComplianceJob getDBKeyByGroupAndName "Path_to_Compliance_Template" "Compliance_Template"

      blcli_storeenv jobKey

      blcli_execute JobRun findLastRunKeyByJobKey $jobKey

      blcli_storeenv runKey

      blcli_execute JobRun jobRunKeyToJobRunId $runKey

      blcli_storeenv runID

      blcli_execute Utility exportJSONServerWiseSummaryReport $runID "//hostname/c/reports"

       

       

      The resason i'm asking is, that i get the following error:

       

      Command execution failed. com.bladelogic.om.infra.app.db.DBException: An error occurred while attempting to access the database:

      Message : No entry in mapping files for query with ID SELECT_COMPLIANCE_RULE_RESULT_BY_RULE SQLState: null ErrorCode: 0

      : java.sql.SQLException: No entry in mapping files for query with ID SELECT_COMPLIANCE_RULE_RESULT_BY_RULE

       

      Just would like to understand if this is a issue in my lab, or if i found a defect.

       

      Steffen

        • 1. Re: Issue with Compliance export in 8.6
          Bill Robinson

          Do you have a query named ‘SELECT_COMPLIANCE_RULE_RESULT_BY_RULE’ in the sqlmap.properties file on your appserver ?  it looks like that’s not there ?  it should be if the upgrade was successful unless it’s missing from the product for some reason.

          • 2. Re: Issue with Compliance export in 8.6
            Steffen Kreis

            Should have mentioned that :-)

             

            It is not there. However there is a deployments_bkp folder with the old stuff, which definitely contains a different sqlmap.properties file. So i think the migration did go well.

             

            Urgh...the Compliance Export is quite an important feature of 8.6 to us.

            Getting "Oracle charecter set mismatch" error, when i try to export from the UI as well.

             

            So i have a ticket open and will report this issue there as well.

             

            Steffen