6 Replies Latest reply on Apr 22, 2015 5:30 AM by Ali SIMON

    Upgrading the agent where BBSA console is installed...

    richard mcleod

      Is there any way around this error without uninstalling BBSA console? I am using the agent installer bundle

       

      I tried upgrading the agent to 8.5.01.260 on a box with BBSA 8.5.01.96 and RSCD 8.5.01.96 installed. It errored out stating there was a dependency on NSH

       

      Info02/06/2015 11:27:29Legacy installation located at /opt/bmc/bladelogic/NSH
      Error02/06/2015 11:27:29NSH dependecy found. Please use package that includes both NSH and RSCD for upgrade
      Info02/06/2015 11:27:29AGENT=8.5.01.96
      Info02/06/2015 11:27:29NETWORK_SHELL=8.5.01.96
      Info02/06/2015 11:27:29CM=8.5.01.96
      Info02/06/2015 11:27:29PMCLIENT=8.5.01.96
      Info02/06/2015 11:27:29JRE=1.7.0
      Info02/06/2015 11:27:29Exiting...
      Info02/06/2015 11:27:29error: %pre(BladeLogic_RSCD_Agent-8.5.01-260.x86_64) scriptlet failed, exit status 254
      Info02/06/2015 11:27:29error:   install: %pre scriptlet failed (2), skipping BladeLogic_RSCD_Agent-8.5.01-260
      Error02/06/2015 11:27:29ERROR: Agent upgrade failed. The upgrade command exited with error code : 1

       

      So I upgraded the BBSA console to 8.5.01.260, then tried the agent installer job again, it's throwing the same error?

       

      Info02/06/2015 11:58:52Upgrade Command is : rpm -Uiv ./RSCD85-SP1-P4-LIN64.rpm
      Info02/06/2015 11:58:52Preparing packages for installation...
      Info02/06/2015 11:58:52Legacy installation located at /opt/bmc/bladelogic/NSH
      Error02/06/2015 11:58:52NSH dependecy found. Please use package that includes both NSH and RSCD for upgrade
      Info02/06/2015 11:58:52AGENT=8.5.01.96
      Info02/06/2015 11:58:52NETWORK_SHELL=8.5.01.260
      Info02/06/2015 11:58:52CM=8.5.01.260
      Info02/06/2015 11:58:52PMCLIENT=8.5.01.260
      Info02/06/2015 11:58:52JRE=1.7.0
      Info02/06/2015 11:58:52Exiting...
      Info02/06/2015 11:58:52error: %pre(BladeLogic_RSCD_Agent-8.5.01-260.x86_64) scriptlet failed, exit status 254
      Info02/06/2015 11:58:52error:   install: %pre scriptlet failed (2), skipping BladeLogic_RSCD_Agent-8.5.01-260
      Error02/06/2015 11:58:52ERROR: Agent upgrade failed. The upgrade command exited with error code : 1

       

      The only way I see around this is to uninstall BBSA, install new RSCD, install new BBSA console... Anyone have any thoughts?