3 Replies Latest reply on Dec 17, 2014 6:56 AM by Amit Mishra

    Passing XML document through ORCA

      Share This:

      Hi All

       

      Strange thing happend

      when im trying to send Soap request from SOAPUi:

       

      <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:soa="http://bmc.com/ao/xsd/2008/09/soa">

           <soapenv:Header>

         <wsse:Security soapenv:mustUnderstand="1" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">

          <wsse:UsernameToken>

          <wsse:Username>AoAdmin</wsse:Username>

          <wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">admin123</wsse:Password>

         </wsse:UsernameToken>

         </wsse:Security>

         </soapenv:Header>

         <soapenv:Body>

            <soa:executeProcess>

               <soa:gridName>MoDGrid</soa:gridName>

           <soa:processName>:Change_and_Incident:ThirdParty_Interface:Change_and_Incident_to_ITSM_Interface</soa:processName>

               <soa:parameters>

               <soa:Input>

               <soa:Parameter>

                  <soa:Name required="true">XML</soa:Name>

                  <soa:Value soa:type="xs:string">

                    <soa:XmlDoc>

                      <Vts>

                       <v1>1</v1>

                      </Vts>

                    </soa:XmlDoc>       

                     </soa:Value>

               </soa:Parameter>

               </soa:Input>

               </soa:parameters>

            </soa:executeProcess>

         </soapenv:Body>

      </soapenv:Envelope>

       

       

      I got message :

      <S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">

         <S:Body>

            <S:Fault xmlns:ns4="http://www.w3.org/2003/05/soap-envelope">

               <faultcode>S:Server</faultcode>

               <faultstring>java.lang.IllegalArgumentException</faultstring>

            </S:Fault>

         </S:Body>

      </S:Envelope>

       

      When I use soa:Text to send any text it is fine, but soa:XmlDoc seem not working. It is strange as the call (similar) was working on friday

      Any Ideas?