1 2 Previous Next 19 Replies Latest reply on Nov 25, 2014 9:42 AM by Patrick O'Callaghan

    PXE Provisioning, PXE-E78 Can't Find Boot Server

    Patrick O'Callaghan

      Having an Issue with Provisioning.


      Attempting to provision an HP Proliant DL380 G4 at a client with Windows 2008 R2, this is the only available test box right now.

      Using Bladelogic 8.3.  PXE, TFTP, and DHCP server are on the same server. There are 2 Authentication App Servers and 3 Job Application Servers.  There may be an issue with which app server is being used, but we are unsure of this.  It seems like when we run the job it is being run off BLApp1, however we have the DHCP rule 211 and 212 set up for BLApp3, we were trying to view records for previously successful provisions but there are no longer any records due to the retention policy.  We were going to try to run report to see if we can find details on which app server ran the provision job but none of the OOTB reports seemed to provide this information and we didn't look at custom reports for this yet.


      DHCP is setting a scope that is on a different subnet than the app server and DHCP/PXE server but it should be accessible from the app server and PXE/DHCP server via a helper.  I don't have access to their network configurations so I had someone confirm that all the switches and helpers were on and communicating properly so that this should not be an issue.  DHCP has options 003 for router, 60 for PXEserver, 211 for BLappserver IP (App Server 3), 212 for BLappserver port (App Server 3), options for DNS servers and Domain name and all were confirmed to be correctly set.


      The Provision target has 4 available MAC Addresses.  We were using what should be the first MAC Address.  This box was previously provisioned using this MAC Address.  We decommissioned the server, and set the MAC Address for re-provision later so it returned to the Imported Devices list.  The Provisioning Configuration PXE Server and TFTP Server should be correct, the Image configuration should all be correct, however it doesn't seem like it is even getting to the boot.bcd.


      When the target starts up in PXE boot and the provision job is running and waiting at 3/16, the target gets an IP address from DHCP so there is communication at that point.  After it gets an IP address it attempts to contact the PXE server and immediately comes back with PXE-E78 Could not locate Boot Server.  I am assuming that this has nothing to do with the images as it doesn't even seem to get that far.  It doesn't get to Boot.bcd.


      We tried pinging the app server from the PXE server and vice versa, and telnet into the app server from the PXE server on port 9831 (port in DHCP scope) and everything worked.  We tried changing the DHCP scope and restarting the DHCP server.  Also tried using a different MAC address that exists on the target.  However on boot of the target, the old DHCP scope still gets allocated and the old MAC address is still the one being contacted, even though we removed the old MAC from the device list and provision job all together.


      Sorry for not including screen shots but I am on site for Q & A and to help out with anything needed so I do not have direct access to their environment so I have tried to be as detailed as possible.  If any Logs in particular are needed I can provide them as requested.


      Any suggestions would be greatly appreciated, Thank you!

        1 2 Previous Next