3 Replies Latest reply on Sep 5, 2014 2:07 PM by Bill Robinson

    Faild to connect to :XXXX 4750

    lei zhang



           when i run the update server property JOB,the Job is error.i found in the log the target ip is not the correct IP。

           but when i run agentinfo ABCDG0001D on bbsa server is ok.





           i add the server into bbsa by hostname,the hostname is add into /etc/hosts





        • 1. Re: Faild to connect to :XXXX 4750
          Santhosh Kurimilla

          Try nslookup <server_name> and find out the correct IP address of the server.

          If the IP Address is changed on the server, you may need to decommission the existing one and enroll again with the new server.

          • 2. Re: Faild to connect to :XXXX 4750
            lei zhang

            Hi Kurimilla:


                 the server is not in the bbsa,and i am sure i had decommission the server from bbsa,but when i add the server to bbsa again from the bbsa console,the error"faild to connect to **** 4750" happen still exits.

            • 3. Re: Faild to connect to :XXXX 4750
              Bill Robinson

              nslookup won't help if the name to ip mapping is in the hosts file..


              the ip that's showing in the log snippet, is that correct ?  it looks like no.  java maintains it's own dns cache so if the server was previously resolved by the appserver that result will be cached until the appserver service is restarted.  it look like this is the case because the ip you showed in the agent info differs from what's in the log snippet.  so you should probably do a couple things.  there are a couple ttl settings in the NSH/br/java/lib/security/java.security file for dns ttl.  you need to change those so that good lookup results are not cached forever.  google for 'java dns ttl' and one of the first couple articles should explain it.  2 restart the appserver service.

              1 of 1 people found this helpful