6 Replies Latest reply on Jun 15, 2015 2:13 AM by Jim Wilson Branched to a new discussion.

    Count not find mount point

    David Archbold

      Hello all,

       

      We've recently began seeing these errors when running jobs against some of our Linux servers.

       

      Info 08/29/2014 09:00:26 The job 'Linux Test BLPackage->Linux Test BLPackage' has failed on server linuxserver

      Error 08/29/2014 09:00:26 Could not find a mount point containing path: /var/tmp/stage/ 

      Info 08/29/2014 09:00:26 Package on server bmcappserver is 346 bytes in size. 

      Info 08/29/2014 09:00:26 Checking size of '//linuxserver/var/bmc/depot/blpackages/38e11dce-8023-4783-ba7a-637d1345b094' 

      Info 08/29/2014 09:00:26 Started running the deploy step job 'Linux Test BLPackage->Linux Test BLPackage' on application server 'bmcappserver-job1'(5) against target server linuxserver

      Info 08/29/2014 09:00:26 Deploy Staging Job:Linux Test BLPackage; Server:linuxserver;  PkgID:"38e11dce-8023-4783-ba7a-637d1345b094-626016.2"; UUID:b2db06270ba63bc9ae201d589af40bd3 

       

       

      This is puzzling to us, because we can log in to the "linuxserver" and verify that /var/tmp/stage is indeed mounted (in fact, /var is the mount point - we do not have a separate mount for tmp or stage at all).   I can also cd over to it and create files (as a normal, non-privileged user) etc.

       

      The BLPackage I'm deploying is a simple test job, all it does is execute a basic built-in command and terminate.   I created it specifically to reproduce this issue, but we've seen it on a variety of deployment jobs.

       

      The application server is 8.5.1, and the RSCD agent on the "linuxserver" is also 8.5.1 (build 96).   Though we're also seeing this on servers running the 8.5.0 (build 469) agent as well.

       

      Oddly enough, we were able to successfully deploy an agent upgrade bundle to the server and successfully upgrade the agent.   That too writes out a directory on /var/tmp/stage and I can verify it both creates it and subsequently executes from it successfully.   Yet when I go back and run a generic deploy job, it fails with the above message.

       

      These errors seem to have started shortly after we updated to the 8.5.1 application server.  However, this doesn't appear to me to have anything to do with the appserver itself, but something on the machine, and like I said above - we're experiencing the issue on agents running 8.5.1 and 8.5.0....

       

      Has anyone else experienced this issue and can recommend a fix action or workaround?  Any help would be appreciated ,thank you!

        • 1. Re: Count not find mount point
          Bill Robinson

          I think this is fixed in a 8.5.01 hotfix.  did you create a support issue for this?  they can get you the hotfix.

          • 2. Re: Count not find mount point
            David Archbold

            Yes, we called BMC support on this issue and they acknowledged that it's a known issue that has been hotfixed.  They are working to get us the installation packages on their FTP site for us now.

            • 3. Re: Count not find mount point

              Had a similar issue with deploying a patch bundle today.  I have upgraded to "Agent Release   : 8.5.01.218", do you know if the fix made it into that release or if I'm experiencing something different?

               

              Info 10/07/2014 07:56:41 The job 'RHEL Patch 65-rhelone-20015601 @ 2014-10-07 07-20-12-210-0700->RHEL Patch 65-rhelone-20015601 @ 2014-10-07 07-20-12-210-0700' has failed on server rhelone

              Warning 10/07/2014 07:56:41 Removed target directory: //rhelone/var/tmp/stage/b7a32150976733f3b93f78f565524dc7

              Error 10/07/2014 07:56:41 Could not find a mount point containing path: /var/tmp/stage/

              Info 10/07/2014 07:56:41 Started running the deploy step job 'RHEL Patch 65-rhelone-20015601 @ 2014-10-07 07-20-12-210-0700->RHEL Patch 65-rhelone-20015601 @ 2014-10-07 07-20-12-210-0700' on application server 'bl-appserv.bmc.local'(2,000,000) against target server 'rhelone'

              Info 10/07/2014 07:56:41 Deploy Staging Job:RHEL Patch 65-rhelone-20015601 @ 2014-10-07 07-20-12-210-0700; Server:rhelone;  PkgID:"7197d44b-7b72-4926-b345-64022fb78c7a-2001567.1"; UUID:b98f8ece307b337b9c8b7d643db07ee3

               

              bl-appserv# cd //rhelone/var/tmp

              rhelone# ls

              rscdlck                         setup_mcsysinfo-noui_log_11444  stage

              setup_mcsysinfo-noui_log_11391  setup_mcsysinfo-noui_log_8374

              rhelone# touch file

              rhelone# ls

              file                            setup_mcsysinfo-noui_log_11391  setup_mcsysinfo-noui_log_8374

              rscdlck                         setup_mcsysinfo-noui_log_11444  stage

               

              rhelone# agentinfo rhelone

              rhelone:

                Agent Release   : 8.5.01.218

                Hostname        : rhelone

                Operating System: Linux 2.6.32-431.el6.x86_64

                User Permissions: 0/0 (root/root)

                Security        : Protocol=5, Encryption=TLS1

                Host ID         : 7F0100

                # of Processors : 1

                License Status  : Licensed for NSH/CM

               

              Thanks

              • 4. Re: Count not find mount point
                David Archbold

                Yes, the update BMC provided that fixed the issue was the 8.5.01.218 application server.

                1 of 1 people found this helpful
                • 5. Re: Count not find mount point
                  Neel Shaha

                  Hello,

                   

                  I am facing the same issue while deploying patrol agent on Linux through BSA BLPacakging. My BSA app server is on version 8.5.01.96 with RHEL 6.2 as OS & looks like applying hotfix 8.5.01.218 to BSA app server is resolution to this issue. So can anyone tell me from where I can download this hotfix?

                   

                  Thanks in advance.

                   

                  Regards,

                  Neel

                  • 6. Re: Count not find mount point
                    Jim Wilson

                    Neel Shaha wrote:

                     

                    looks like applying hotfix 8.5.01.218 to BSA app server is resolution to this issue. So can anyone tell me from where I can download this hotfix?

                    It's available from the usual EPD site (Follow the Product Downloads link from http://www.bmc.com/support )

                     

                    Build 8.5.01.218 is 8.5 Service Pack 1 Patch 1 (AKA 8.5.01.001)

                     

                    I would suggest installing 8.5 Service Pack 1 Patch 5 HotFix1 as the latest build for BSA 8.5, or even 8.6 SP1