13 Replies Latest reply on Jul 10, 2014 7:23 AM by Bill Robinson

    Building Component Template


      Hi everyone,

       

      I'm trying to build a Component Template for the Windows RSCD agent.

       

      Here's the parts that I have add:

       

      Component Template.jpg

      My question is: When I run a discover on a server with these component template, why the component is empty on the server?

       

      If you check the printscreen, we have no information on the version, install date, etc... I dont't understand why. It's must display this information, right? It's the same thing for the service. We have no information display about it.

       

      Component Template2.jpg

       

      Someon have an idea? Thank you very much all!

        • 1. Re: Building Component Template
          richard mcleod

          What information are you after here?

          • 2. Re: Building Component Template

            Hello lobsters,

             

            I don't understand why I don't see the version, size, ... about the RSCD agent. The RSCD agent is installed on the server. I'm searching to know if I should see this information in the component "BL - Windows RSCD Agent" that I have created?? And, if i should see it, which configuration is incorrect?

             

            Thanks fo your support.

            • 3. Re: Building Component Template
              richard mcleod

              This worked for me...

              Capture.PNG

               

              Does your template allow Browsing of the object?

               

              Capture.PNG

              • 4. Re: Building Component Template

                Yes! The template allow Browsing of the object. See the printscreen.

                 

                I don't understand why it doesn't work for me.

                 

                Anything else to check?

                 

                Component_template_3.jpg

                • 5. Re: Building Component Template
                  richard mcleod

                  Whats the version of your agent, whats the version of your bsa appserver, whats the version of your bsa rcp client?

                  • 6. Re: Building Component Template

                    Version of agent: 8.5.00.416

                    BSA appserver: 8.5.00.469

                    BSA rcp client: 8.5.00.469

                    • 7. Re: Building Component Template
                      richard mcleod

                      Might be a bug... I would open a ticket with BMC. Anything showing in the rscd log on the target during discovery/live browse?

                      • 8. Re: Building Component Template


                        No! Nothing in the logs end the job complete successfully.

                         

                        Thank you!

                        • 9. Re: Building Component Template
                          Amit Gupta

                          What's in your discovery rule? When you live browse the component on the server, do you see any rscd log entries?

                           

                          Thanks,

                          Amit

                          • 10. Re: Building Component Template
                            Bill Robinson

                            are you mapped to the local admin account on the target ?  can you try the following:

                             

                            - on the target server cd into the <install>\RSCD\sbin directory

                            - run 'agentctl toggle'  this will enable debug logging on the agent

                            - live browse the target

                            - run 'agentctl toggle'  to disable the debug logging

                            - attach the rscd.log here using the 'advanced editor'

                            • 11. Re: Building Component Template

                              Hello Amit!

                               

                              In the discovery rule, we have: ??TARGET.OS?? equals "Windows". The discovery rule is ok. It's working. The components is created on the server. But not display the info about the application. I don't see anything special in the rscd log.

                              • 12. Re: Re: Building Component Template

                                Hi Bill!

                                 

                                Here's the log. I have made a Discover of the Component Template. After, I have Live Browse the server.

                                 

                                ebc5bf153a42978955c6 0000006912 07/09/14 11:30:17.666 INFO     rscd -  server01 1364 SYSTEM (Not_available): (Not_available): Modifying Agent log level from  INFO1  to DEBUG

                                41ad735b3570499922f5 0000006913 07/09/14 11:31:32.562 DEBUG    rscd -  server01 2896 SYSTEM (Not_available): (Not_available): FIPS already enabled

                                aa20d0ef42591627f223 0000006914 07/09/14 11:31:32.562 DEBUG    rscd -  10.254.182.82 2896 SYSTEM (Not_available): (Not_available): Enabling keepalive on the connection

                                d982aae4efc220e6914e 0000006915 07/09/14 11:31:32.562 DEBUG    rscd -  server01 2896 SYSTEM (Not_available): (Not_available): Before first LookupAccountName in initFromUsernameDomain in RSCD_WinUser.cpp.  The domain string is : 'INT.DOMAIN.LOCAL' ; The username string is : 'sysblprod'

                                09e33e52cfce8a1e5190 0000006916 07/09/14 11:31:32.672 DEBUG    rscd -  server01 2896 SYSTEM (Not_available): (Not_available): In refreshNames() in RSCD_WinUser.cpp.  The u_NTDomainUsername string is : 'DOMAIN\sysblprod' ; The u_UPN string is : 'sysblprod@INT.DOMAIN.LOCAL'

                                ddca1ff2b59d0d1378fb 0000006917 07/09/14 11:31:32.672 DEBUG    rscd -  server01 2896 SYSTEM (Not_available): (Not_available): RSCD_WinUser:logonPassword - user name is 'sysblprod'

                                071a82f55668a9e369b0 0000006918 07/09/14 11:31:32.672 DEBUG    rscd -  server01 2896 SYSTEM (Not_available): (Not_available): RSCD_WinUser:logonPassword - domain name is 'INT.DOMAIN.LOCAL'

                                4bfbbd626551c22d00b5 0000006919 07/09/14 11:31:32.796 DEBUG    rscd -  10.254.182.57 2896 sysblprod@DOMAIN.LOCAL:PasswordLogon (WindowsAdminLevel3:PoloM@INT.DOMAIN.LOCAL): CM: ***** New connection *****

                                867913953601e8ac6604 0000006920 07/09/14 11:31:32.796 INFO     rscd -  server01 2896 sysblprod (Not_available): (Not_available): The operation completed successfully. 

                                8d7099dcd36a5744ecc8 0000006921 07/09/14 11:31:32.796 INFO2    rscd -  10.254.182.57 2896 sysblprod@INT.DOMAIN.LOCAL:PasswordLogon (WindowsAdminLevel3:PoloM@INT.DOMAIN.LOCAL): CM: uname () = 0

                                d5a25d8ed34406da5a66 0000006922 07/09/14 11:31:33.998 INFO     rscd -  server01 1912 SYSTEM (Not_available): (Not_available): Main: Starting AgentHouseKeeping.

                                097b9692af16eb301585 0000006923 07/09/14 11:31:33.998 DEBUG    rscd -  server01 1912 SYSTEM (Not_available): (Not_available): AgentHouseKeeping

                                5be446ad600b2f91b7e3 0000006924 07/09/14 11:31:55.635 INFO     rscd -  server01 1364 SYSTEM (Not_available): (Not_available): Modifying Agent log level from  DEBUG  to INFO1

                                 

                                 

                                And, if I go in my Component Template "RSCD Agent", I can browse the and the info about the application is ok.

                                Components_Template_4.jpg

                                But, if live browse the server and I go to the component template, the info is not there.

                                 

                                Component Template2.jpg

                                • 13. Re: Re: Building Component Template
                                  Bill Robinson

                                  that may be a gui defect - i would expect both views to be the same there...