1 Reply Latest reply on Jun 28, 2014 10:09 PM by Raja Mohan

    compliance scan fails - extended object

    Raja Mohan

      I have a compliance template when run from a job fails with permission errors

      [28 Jun 2014 16:02:12,739] [WorkItem-Thread-46] [INFO] [nn@xxx.com:BLAdmins:] [Compliance] Started pid 21743: scriptutil -d "/var/tmp/stage" -s "GIS-Scan-Policies/RHEL/RHEL6/RHEL6-v01/sshd-loglevel.sp" -h "sto_bsavlnx_demo"

      [28 Jun 2014 16:02:13,870] [WorkItem-Thread-46] [ERROR] [nn@xxx.com:BLAdmins:] [Compliance] com.bladelogic.om.infra.app.collector.AssetCollectionException: Unable to copy script "GIS-Scan-Policies/RHEL/RHEL6/RHEL6-v01/sshd-loglevel.sp" to host sto_bsavlnx_demo: Permission denied

      (component=FTT-Linux-rh6-v01 (sto_bsavlnx_demo), selector=Extended Object:sshd-loglevel.sp)


      but the same command works when invoked from a NSH console. I dont find any errors anywhere else.


      scriptutil -d /var/tmp/stage -s GIS-Scan-Policies/RHEL/RHEL6/RHEL6-v01/sshd-loglevel.sp -h sto_bsavlnx_demo


      <::>LogLevel INFO</::>



      what am i missing?

        • 1. Re: compliance scan fails - extended object
          Raja Mohan

          Found the root level directory didn't have permission. When i run the NSH I was as root and was able to access the file, i believe when the job runs it was using bladmin and didnt have authority to read the file. Added an strace in front of the script util in job and found it was failing on opening the file for read.


          Fixed it and came cross additional errors (missing disa* files) etc. I am able to run the compliance scan now. thanks