1 2 Previous Next 26 Replies Latest reply on Sep 2, 2014 3:06 PM by Yanick Girouard

    RSCD Agent Issue


      Hi All

       

      Am new to the BSA toll am struck with the Agent issue.

      We are unable to telnet the agent with the port 4750.tried below steps to reach the agent , Agent status in the Server shows "Agent is not available"

      Step 1 : Restarting the agent in the targer servere

      Step 2 : Telneting the server with the respective  port detail

       

      Please help me in resolving the issue.

        • 1. Re: RSCD Agent Issue
          Davorin Stevanovic

          could you please send us:

           

          rscd.log from RSCD_Install_dir

          output of the following command: netstat -an | find "4750" (if on windows) or netstat -an | grep 4750 (if on linux)

          • 2. Re: RSCD Agent Issue

            rscd.log :

             

            05/30/14 19:53:59.861 INFO rscd - aiscrmdb-sv001.ais-fr.com 4720 -1/-1 (Not_available): (Not_available): FIPS Enabled
            05/30/14 19:53:59.861 INFO rscd - aiscrmdb-sv001.ais-fr.com 4720 -1/-1 (Not_available): (Not_available): Agent version is 8.2.02.321
            05/30/14 19:53:59.861 INFO rscd - aiscrmdb-sv001.ais-fr.com 4720 -1/-1 (Not_available): (Not_available): Platform Details: x86_64;aiscrmdb-sv001.ais-fr.com;2.6.18-371.8.1.0.1.el5;Linux;#1 SMP Thu Apr 24 13:43:12 PDT 2014;x86_64

             

            Output of the command :

             

            [root@aiscrmdb-sv001 ~]# netstat -an | grep 4750
            tcp 0 0 0.0.0.0:4750 0.0.0.0:* LISTEN
            [root@aiscrmdb-sv001 ~]#

            • 3. Re: RSCD Agent Issue
              Davorin Stevanovic

              This looks like its correctly running, could you please run from NSH: agentinfo <your targer server> and see if you will receive output. Also try running USP job (Update Server Propery job) against this server and let me know if the agent still shows as not available.

              • 4. Re: RSCD Agent Issue

                After running the NSH am getting the below result ;

                STSOT005% agentinfo 10.104.201.161

                10.104.201.161:

                  Agent Release   : 8.3.02.332

                  Hostname        : PPPRALZNIM1003

                  Operating System: AIX 6.1

                  User Permissions: -2/-2 (nobody/nobody

                  Security        : Protocol=5, Encrypti

                  Host ID         : A68C9A1

                  # of Processors : 4

                  License Status  : Licensed for NSH/CM

                 

                 

                After running the USP still am getting the Agent_Status = Agent is not responding

                • 5. Re: RSCD Agent Issue
                  Santhosh Kurimilla

                  Please check secure, exports, users.local and users file for user mapping.

                  • 6. Re: RSCD Agent Issue
                    Bill Robinson

                    did you run the 'agentinfo' from your appserver or client?

                     

                    if not the appserver, then can you verify the appserver can communicate to 4750 on the target?  if it can't, that would seem to be a network issue.

                     

                    then you would want to check the users.local file and ensure the bladelogic user you have logged into the gui is mapped to a local administrator.

                     

                    the 'agent is not available' property value is updated when a 'update server property' job runs or if you right-click and do a 'verify' on the target.  so it's possible to communicate w/ the target even if the property is set to 'not available'.

                    • 7. Re: RSCD Agent Issue


                      Santhosh ,

                       

                      As am new to this tool , From where i need to take those log files (either from the client side or from our side)

                       

                      how can we evaluate it ?

                      • 8. Re: RSCD Agent Issue
                        Barry McQuillan

                        On the Target server AIX the users, users.local and exports files can be found in /usr/lib/rsc.

                        Unless you used the -local switch to install in which case they will be under <INSTALL_DIR>/NSH/conf.

                         

                        The logs should be on the target server.

                        You could also look in the appserver log for the corresponding entries.

                         

                        On the Target server:

                        # ps -ef | grep rscd

                        you should see the rscd processes running.

                         

                        From appserver telnet to target server on port 4750.

                        On the appserver run:

                        # nsh

                        # agentinfo <target server>

                         

                        If you cannot connect using telnet, does a traceroute work?

                         

                        If neither telnet nor traceroute work then I'd look for either a firewall dropping the packets or else a routing issue.

                        Are there any local firewalls install on the target server?

                        • 9. Re: RSCD Agent Issue

                          Hi Bill ,

                           

                          I ran the Command in the our Appserver not from the client.

                          I tried telnetting stil no result . its not connecting itself. getting the timeout error.

                          • 10. Re: RSCD Agent Issue

                            Untitled.pngHi  McQuillan ,

                             

                            Please find above observation found by client

                            • 11. Re: RSCD Agent Issue
                              Rajeev Gupta

                              Please update your users.local as

                               

                              BLAdmins:BLAdmin rw,map=root


                              And Exports as


                              * rw, user=root


                              Restart the Agent.


                              Also, add the host entries for the Managerd server in the App server if the server is not able to resolve the name.

                              • 12. Re: RSCD Agent Issue
                                Rajeev Gupta

                                Also check the routing settings if the proper route entries are made in the server.

                                • 13. Re: RSCD Agent Issue

                                  Hi Rajeev ,

                                   

                                  How can i check the Routing setting ?

                                  • 14. Re: RSCD Agent Issue

                                    HI Rajeev ,

                                     

                                    Where can i get the user.local file ?

                                    1 2 Previous Next