5 Replies Latest reply on May 22, 2014 6:08 AM by Bill Robinson

    users and export file in an application server

    Raja Mohan



      we executed OS patched our application server and database server in development environment. After the restart, the compliance test rules were failing with error message "Connection Refused". we had also observed the application server on the server list was showing under "Agent not Responding". When we attempted to do verify, i received same "Connect Refused".

      example of error messages in log

      Error May 21, 2014 1:27:12 PM com.bladelogic.om.infra.app.collector.AssetCollectionException: nsh:1: connection refused:


      I also noticed under "Configuration -> Infrastructure Management -> Application Servers -> the hostname -> FileManagerService" reporting "File Server Mount Point Info = unknown"


      Our exports file had * mapped to user=root and users/users.local was empty. I added user bladmins:* mapped to the user in users file then followed with a verify failed with "connection refused". Now we restarted rscd agent and was able to successfully perform a verify and the application server moved to "All Servers" smartgroup. I also pushed the ACL from the console to this application server after a successful live browse using bladmin. The errors generated while running compliance template disappeared, now on the "Configuration -> Infrastructure Management -> Application Servers -> the hostname -> FileManagerService" has the following populated instead of unknown

      File Server Total Disk Space (B) = 524288000

      File Server Free Disk Space (B) = 476279232


      The users file has not been modified since last year except for the recent update of OS patches and reboot of application servers. After everything is working we removed and reset the users file back to original (empty) and everything seem to continue to work. Couple of questions, I am trying to find a reasonable explanation for the behavior of agent and errors. Any insight is helpful


      what is the difference now it is working? would this configuration stop working if i reboot the server again? what should be the defaults for  application server export, users and users.local file should be?