5 Replies Latest reply on May 6, 2014 1:57 PM by Bill Robinson

    BLCLI Get Logs

    Jared Murrell

      I'm trying to grab the logs of a recent job run using BLCLI, but I'm getting the following error:


      Command execution failed.  An error occurred while attempting to access the database:

      Message : No value specified for parameter: JOB_ID; QUERY: SELECT job_event_id, guid,job_id, job_version_id, job_run_id, event_type_id, event_date, server_name, device_id, component_id, component_version_id, result_id, audit_object_id, message, is_overflow, object_overflow_id, is_deleted FROM job_run_event WHERE job_id = ? and job_version_id = ? and job_run_id = ? ORDER BY event_date, job_event_id; JOB_ID, JOB_VERSION_ID, JOB_RUN_ID SQLState: null ErrorCode: 0


      The command I'm using is:


      blcli_execute JobRun getLogItemsByJobRunId DBKey:SJobRunKeyImpl:1234567 1234567


      I've tried a few of the unreleased commands, but I get the same result. If I use a bogus DB key then I get a different error.