0 Replies Latest reply on Apr 8, 2014 3:28 PM by richard mcleod

    Unexpected exception in the agent communication layer

    richard mcleod

      So I've been trying to figure out why most if not all IBM AIX LPAR systems enrolled in my environment are unable to relay data from the following object: Hardware Information -> Hardware -> Storage Devices -> Logical Storage Devices.


      I have a ticket open with BMC, the steps taken so far were to enable debug messages in the rscd.log by replacing the word 'info' in the log4crc.txt file with the word 'debug', restarted the agent for the change to take effect. Next to drill down through the hardware information object.


      On the random system I chose, the error message that was showing the rscd.log was this:

      04/08/14 16:10:34.121 ERROR    rscd - 31522886 0/0 (BLAdmins:me@.COM): CM: cannot execute command : "/opt/bmc/bladelogic/NSH"/nativetool/bin/sysinfo  --cache NO --format report -repsep '|' --widechar -msglevel all -class General,Partition

      04/08/14 16:10:34.121 ERROR    rscd - 31522886 0/0 (BLAdmins:me@.COM): CM: sh: /opt/bmc/bladelogic/NSH/nativetool/bin/sysinfo:  not found

      So OK - with this one I tried to run the sysinfo command alone, however it actually doesn't exist. I did find the install in /opt/bmc/bladelogic/NSH/nativetool_installer/ - running the 'sysinfo_installer' from here produces this

      bash-3.2$ sysinfo_installer



              SysInfo runtime with no User Interface version 10 H5 for aix-powerpc

                      Self-extracting Archive



      Verifying archive integrity ... Error in md5 sums 2CAFDBA912B047387F640C4C0DBB4CE5

      Here is where I've gone off alone...

      I ran a compliance job on the AIX environment and found 57 that actually do have the sysinfo binary installed, also spoke with a colleague about the sysinfo binary not being installed and it was mentioned that it never installed properly.


      I took to one of the 57 and first attempted to drill to the Hardware Information -> Hardware -> Storage Devices -> Logical Storage Devices object but same result, nothing was output. So I updated the log4crc.txt on this host to enable debugging, restarted the agent and now when I click the hardware information object in live browse i receive the error "Unexpected exception in agent communication layer."


      I've run the sysinfo tool from an ssh session on the host, and found it dumps out 610 lines of information, assuming the cause of my error is too much data? Anyone else run into this?


      I've turned DEBUG off and now the Hardware Information objects works as expected sans Logical Storage Device information.


      Also I've confirmed that the same issue exists on BSA 8.2.03 and 8.3.02