3 Replies Latest reply on Apr 8, 2020 10:09 AM by Ezra Wise

    'Create Entry' and interaction with SB:ServiceRequestStub

    Ezra Wise
      Share This:

      Hello,

       

      I am creating a record in AR directly using the 'Create Entry' Remedy connector widget.  I am creating a record in "HPD:IncidentInterface_Create" because I want to set values that aren't otherwise available using the "Create Incident" widget (like 'CI Name' and overwriting the default customer 'Site' information).

       

      However, using 'Create Entry' isn't working as expected.  The SB:ServiceRequestStub entry does not include all of the same information as the stub record created using the 'Create Incident' method.  Additionally, when I have a 'Receive Task' in the workflow I get the status "No Response" for the Service Request:

       

       

      Stub record created using 'Create Incident':

      Compared to the stub record created using 'Create Entry':

       

      The "HPD:IncidentInterface_Create" entries look basically identical, with the exception of the added 'CI Name' and alternate 'Site' information.

       

      So to summarize, the SR that uses the 'Create Incident' widget and contains a 'Receive Task' works as expected - waiting for the appropriate Result to be returned before continuing.  The SR that uses the 'Create Entry' widget and contains a 'Receive Task' gives the "No Response" status.  The only thing I can see in the bundle.log file is:

       

      com.bmc.myservice.common.util.exception.MyServiceException: [ERROR (909): The process does not exist on the server.; Process Definition Name: <myit-sb:Standard IT Request> process Instance ID: <IDGAAEHXAAW4NAQI39R7QI39R75NZV>]

       

      This error occurs after I update the Incident record (change status to "Resolved") and cause it to send the status update back to DWP Catalog, which puts the SR into a "Fault" state.

       

      I've attempted to re-associate the Workflow with the SR a few times, but no luck.  The "Standard IT Request" is the name of the Process Workflow in the SR.  I also tried to create workflow on the AR Server to automatically populate the additional SR Stub details that are missing when created using 'Create Entry', but that had no effect.

       

      I would appreciate any insight into what might be going on, how DWP Catalog is generating those stub entries, or how I can figure out how to work with 'Create' Entry' properly so that it creates a usable stub entry for interaction between ITSM and DWPA.  Thanks!