7 Replies Latest reply on Dec 31, 2019 5:25 AM by Menna Hassan

    no patrol agent associated with managed devices

    Menna Hassan
      Share This:

      when trying to add policy no agent was previewed !!!

      i Just opened the "Agent Selection Criteria" in the infrastructure policy and clicked "Preview" but there were no PATROL Agents that match the filter criteria.
      The PATROL Agents are connected to the integration service.

       

      what are the right steps to add patrol agent for infrastructure management on presentation server (truesight console ) ?

        • 1. Re: no patrol agent associated with managed devices
          Abhijeet Padlamwar

          HI Menna,

           

          Can you confirm if you have added the integration service in TSPS to which your PA are connected? If yes, than check if you can see PA in TSIM console.

           

          Secondly if you are adding multiple PA in agent selection criteria than please use OR operator between two or more PA.

           

          For clear understanding if possible you can provide screenshot.

           

          Kind Regards,

          Abhijeet P

          1 of 1 people found this helpful
          • 2. Re: no patrol agent associated with managed devices
            Menna Hassan

            yes i have installed  IS , TSIM & TSPS on the same host (for POC Environment ) ,,,, and i have installed PA on the host that i want to monitor ,,also i added TSIM to TSPS in truesight console

            what are the steps from the begining after adding IS toTSIM to monitor some host(windows server)  using PA and how to connect with IS through Truesight console because i am lost with the documentation .

             

            can't find agent when i click preview

            • 3. Re: no patrol agent associated with managed devices
              Michael Ashall

              When you created the package and installed what integration variable did you use?

               

              The PA will communicate back to the IS on the port you gave also.

               

              If the PA is running the agent correctly then you need to check the Port.

               

              We have a nice utility for checking firewalls CLI Supportability Improvements | TrueSight Operations Management

               

              If you are familiar with wpconfig you can see the variable at source also.

               

              /AgentSetup/integration/integrationServices = tcp:hostname.bmc.com:3183

              • 4. Re: no patrol agent associated with managed devices
                Michael Ashall

                screenshot.7700.jpg

                 

                What do you see under managed Devices?

                 

                If this is not connected here then configuration will the issue issue

                 

                 

                Check

                 

                a) %PATROL_HOME%\log\PatrolAgent_HOSTNAME.errs

                Sun Dec 29 21:01:47 2019: ID 1021fa: I: Connection established with Integration Service HOSTNAME.BMC.COM on port 3183

                If you don't see this then supply error

                 

                Please confirm the PA is not installed on the same "TSOM" environment - i.e. remote.?

                • 5. Re: no patrol agent associated with managed devices
                  Menna Hassan

                  the agent is disconnected .... could you please tell me the right steps to make an agent monitor host and send data to TSPS ?
                  like for example: 1- i should first import package and its setting is ......
                  i am new to the tool so i cant aggregate all the information

                   

                  why patrol agent is disconnected ?

                   

                  what do you mean by configuration will the issue issue ? what is the exactly configuration ?

                   

                   

                  Mon Dec 30 11:18:49 2019: ID 10212e: E: ERROR: initialiseCosSubsystem() - createServer() - tcp:localhost:2059

                  Mon Dec 30 11:19:19 2019: ID 1021fa: I: Connection established with Integration Service XXXXX on port 3183

                  Mon Dec 30 11:19:29 2019: Discarding Invalid Stats Cache

                  Mon Dec 30 11:19:38 2019: ID 1020a3: I: Normal Shut Down Request due to Service Exit

                  Mon Dec 30 11:19:39 2019: ID 102062: I: PatrolAgent terminating

                  Mon Dec 30 11:19:39 2019: ID 1021c5: I: History File Closed Successfully

                  Mon Dec 30 11:19:39 2019: ID 1021c6: I: PEM File Closed Successfully

                  • 6. Re: no patrol agent associated with managed devices
                    Michael Ashall

                    Ignore the COS as this is related to old technology that you are not using

                     

                    The connection appears to be made

                    Connection established with Integration Service 192.168.1.214 on port 3183

                     

                    The agent then shuts down the connection.

                     

                    Recommend you log a BMC Support case

                     

                    Attached the TSIS Logs , and PA logs.