1 2 Previous Next 15 Replies Latest reply on Sep 12, 2019 6:44 AM by Sachinkumar Ambulgekar

    BMC Smart Reporting installation error

    Saurabh Maheshwari
      Share This:

      Hi Experts,

       

      We are doing fresh installation of BMC Smart Reporting on standalone server. Below are the environment detail :

       

      Smart reporting version 19.08

      OS Type : Linux

      Sever : Standalone (we are doing installation of smart reporting on separate server, not using AR System server)

      Java version -

      openjdk version "1.8.0_222"

      OpenJDK Runtime Environment (build 1.8.0_222-b10)

      OpenJDK 64-Bit Server VM (build 25.222-b10, mixed mode)

       

      We run the setup and installation has failed with below error. please suggest how to fix this.

       

      (Sep 01 2019 09:14:12.185 AM +0400),SEVERE,com.bmc.install.product.arsuitekit.platforms.arsystemservers.reporting.task.ReportingInstallTask,

        LOG EVENT {Description=[ERRROR : Error returned by SmartReporting process ::],Detail=[E

        xception in thread "main" java.lang.UnsupportedOperationException

      at java.util.AbstractList.remove(AbstractList.java:161)

      at com.hof.installer.Installer.loadDatabases(Installer.java:838)

      at com.hof.installer.Installer.initialise(Installer.java:411)

      at com.hof.installer.Installer.main(Installer.java:783)

      ]}

       

      Regards,

      Saurabh

        • 1. Re: BMC Smart Reporting installation error
          Stefan Hall

          I'm not quite sure I mean openjdk 8 is an unsupported java version for 1908.

           

          Try openjdk11 or new with version 1908 openjdk 12. If it should be Java 8, use Oracle Java.

          3 of 3 people found this helpful
          • 2. Re: BMC Smart Reporting installation error
            Saurabh Maheshwari

            Hi Stefan,

             

            I have installed later version of Java but still installation is failing with same error.

             

            latest java version is

            java version "12.0.2" 2019-07-16

            Java(TM) SE Runtime Environment (build 12.0.2+10)

            Java HotSpot(TM) 64-Bit Server VM (build 12.0.2+10, mixed mode, sharing)

             

             

            Regards,

            Saurabh

            • 3. Re: BMC Smart Reporting installation error
              Oliver Ruoss

              Hi

               

              I tried all kinds of Java Version but it resulted always in the same error.

               

              Finally I used the embedded tomcat with the installer - not external. This solved the issue an Smart Reporting could be installed.Anyways - its unfortunate. For SmartReporting and Smart IT 19.08 we cannot use external Tomcats anymore.

              • 4. Re: BMC Smart Reporting installation error
                Stefan Hall

                Interesting, internal or external cannot be the real reason. Tomcat doesn't know this difference, only BMC can.

                 

                Do you use the same Tomcat version externally? This is often not the case, because BMC reacts much too slowly to security updates from Tomcat, releases every 6 months are much too slow from a security point of view and until you have it in production, more months pass. Therefore we only use external tomcat installations.

                 

                Can you please compare the two Tomcat versions?

                Did you update Tomcat together with Smart reporting?

                2 of 2 people found this helpful
                • 5. Re: BMC Smart Reporting installation error
                  Thomas Hammer

                  Hi Stefan Hall,

                  this is one of the main reasons we prefer to use an external Tomcat. The other one is governance. Some companies have released a spefic version only and are monitoring the use of version that are not white-listed.

                  But we have several installations (different customers) where the external failed, for Smart-IT and for Smart-Reporting and only the internal (embedded) did work.

                  It's such a time consuming investigation work and we had several web-ex sessions with BMC without success.

                  It is really not only annoying but frustrating.

                  Projects ran out of time due such errors.

                  We feel left alone by BMC, for no explanation is provided at all, why the embedded will work while the external will not.

                  3 of 3 people found this helpful
                  • 7. Re: BMC Smart Reporting installation error
                    Stefan Hall

                    Hi Thomas,

                    until 1902 we never had any problems with external tomcats and smart reporting. Maybe it's a new 1908 problem?

                    • 8. Re: BMC Smart Reporting installation error
                      rami ghoul

                      Hi Saurabh,

                       

                      I was facing the same issue earlier, but I am able to install smart reporting 19.08 successfully now on separate server with the embedded tomcat.

                      Kindly double check the following points:

                       

                      1-Uninstall any existing installation for Smart Reporting and delete the files under BMC/ARSystem

                      2-Make sure to delete Smart Reporting database

                      3-Delete temp and %temp% folders

                      4-Run the installer for Smart Reporting

                       

                      After I perform the above steps I was able to install it successfully.

                       

                      Regards,

                      Rami.

                      • 9. Re: BMC Smart Reporting installation error
                        Thomas Hammer

                        Hi Stefan,

                        the issue with external tomcat in general has occured with 18.05, 19.02 and 19.08 (Smart-IT and DWP)

                        The specific issue with Smart Reporting did occur with 19.08.

                        And again a have to complain that BMC support is not able to tell us how to get around this issue. In the end we have to use and outdated embedded version.

                        3 of 3 people found this helpful
                        • 10. Re: BMC Smart Reporting installation error
                          Thomas Hammer

                          Hi Rami,

                          yes embedded should work, and did for us.

                          But how to execute a successful installation with an external tomcat?

                          • 11. Re: BMC Smart Reporting installation error
                            rami ghoul

                            Hi Thomas,

                             

                            Earlier even the embedded tomcat was not successful with me , for external tomcat I tried the following versions of tomcat :

                            apache-tomcat-8.5.5

                            apache-tomcat-8.5.6

                            apache-tomcat-8.5.43

                            apache-tomcat-8.5.45

                            apache-tomcat-9.0.7

                            apache-tomcat-9.0.21

                             

                            Neither of the above tomcats worked with smart reporting, so I guess there is an issue with the installer files for the external tomcat step.

                             

                            Regards,

                            Rami.

                            4 of 4 people found this helpful
                            • 12. Re: BMC Smart Reporting installation error
                              Stefan Hall

                              Hi Thomas,

                              we're moving a little away from the smart reporting topic, but I'm doing it again

                               

                              We don't have any problems with DWP and an external Tomcat up to and including 1905. However, 1902 and 1905 was an update and not a fresh installation. Only after manual RSSO integration according to BMC instructions DWP didn't start. The manual is not correct since 1905, more libs have to be copied. After that we could start DWP without problems. The error message was irritating and it was pure luck that we had tried this.

                              • 13. Re: BMC Smart Reporting installation error
                                Thomas Hammer

                                Hi Stefan Hall,

                                I don't think that we are moving away. Any similar issue might help to narrow the root cause for the specific case. Things you might not even thought of before, may be helpful to see the whole picture.

                                Let's assume that BMC is using some sort of shared code for their installer or for their embedded / external Tomcat installation. Any change of that code may have an effect on the first installer with GA status. "I've already seen that effect before" may help to find the reason for that behavior.

                                Back to Smart-Reporting: As I said we faced that external Tomcat issue with Smart-Reporting in 19.08, but not before. Others (rami ghoul) even had problems with the embedded one until they've changed "something". And we (resp. BMC) need to find out what exactly this "something"  is (or more than one ) for all the installation issues where Tomcat is involved (see rami's post from ).  From an analytical point of view the more information you have the better your diagnosis can be. For I don't think that this is an isolated issue.

                                2 of 2 people found this helpful
                                • 14. Re: BMC Smart Reporting installation error
                                  Stefan Hall

                                  Hi, Thomas,

                                  I understood Smart Reporting, problems exist since version 1908.

                                   

                                  In my last post I referred to DWP and there we have no problems up to and including version 1905. That seems to be different with you.

                                  Currently we do not use SmartIT, too unfinished

                                  1 2 Previous Next