4 Replies Latest reply on Apr 4, 2018 2:21 AM by Shaun Smit

    Failed to run FTS Index Migration Utility 9.1.04

    Shaun Smit

      Hi Community,

       

      I have a FTS issue with my 9.1.04 upgrade from 8.1.02.

       

      Pre-Check passed FTS

       

       

       

      Extract from the error logs

       

      (Mar 13 2018 11:27:40.663 AM +0200),SEVERE,com.bmc.install.product.arsuitekit.platforms.arsystemservers.arserver.ARServerFTSIndexMigrationTask,

        LOG EVENT {Description=[arserver.installer.preupgrade.descriptionFailed to run FTS Index Migration Utility]}

       

      (Mar 13 2018 11:37:03.236 AM +0200),SEVERE,com.bmc.install.task.InstallationStateHelper,

        LOG EVENT {Description=[AR System Server  failed],Detail=[featureARServer]}

      (Mar 13 2018 11:37:03.236 AM +0200),CONFIG,com.bmc.install.task.InstallationPropertiesHelper,

        LOG EVENT {Description=[SET PROPERTY FAILED_INSTALL_FEATURES],Detail=[featureARServer]}

      (Mar 13 2018 11:37:03.236 AM +0200),SEVERE,com.bmc.install.product.arsuitekit.platforms.arsystemservers.arserver.ARServerPostUpgradeInstallationTask,

        LOG EVENT {Description=[[resultType=COMPLETED,exitCode=1025]],Detail=[RIK command ( returned a RETURN code of 1025, which was interpreted as a failure from RIKJ ]}

       

      This is our POC server. We do have FTW enabled on our production box. I have disabled FTW, removed the license, cleared out the collectors and tried 9.1.03. I know there is a silent install that I can ignore the utility but we do need to run it. If anyone has any input it would be greatly appreciated.

       

      Cheers

      Shaun

        • 1. Re: Failed to run FTS Index Migration Utility 9.1.04
          Ravindrakumar Rodge

          Can you attach the arsysteminstall_log.txt file?

           

          Looks RIK is failed. Probably there must be a RIK command few lines before the error is reported.

           

          If you could attach AR System Maintenance Logs then it would be pretty useful.

           

          Thanks.

           

          Regards,

          Ravi

          • 2. Re: Failed to run FTS Index Migration Utility 9.1.04
            Mark Walters

            There are two separate errors recorded there.  The FTS migration is one but it looks like it was not considered fatal as the install progressed to importing workflow and it's one of these that also failed and aborted the install.  Check the ARSystem\Logs directory where there should be an ARServer-RIK_PostUpgrade.log with more details of which def failed and why.

            • 3. Re: Failed to run FTS Index Migration Utility 9.1.04
              Shaun Smit

              I have a support call logged for this.

               

              What was identified is the following files did not import during the upgrade:

               

              BMC Software\ARSystem\ARServer\installforms\en\VisualizerModule701.arx is returned with code 1025
              BMC Software\ARSystem\ARServer\installforms\en\VisualizerModule.arx is returned with code 1025
              BMC Software\ARSystem\ARServer\installforms\en\RSSFeed.arx is returned with code 1025
              BMC Software\ARSystem\ARServer\installforms\en\ChatModule.arx is returned with code 1025
              BMC Software\ARSystem\ARServer\installforms\en\Share_Application_Report.arx is returned with code 1025

               

              The advise was to import these manually and try again but I see they are not there, more than likely why it failed. Will update when I have more info.

              • 4. Re: Failed to run FTS Index Migration Utility 9.1.04
                Shaun Smit

                So after a call with BMC, turns out we needed to clean up any old server group rows of data and ranks and clear out any data in ft_pending even though we are not using server groups, I believe v9 automatically puts you in a server group.

                 

                Here is what I did in SQL before running the installer.

                 

                Change the Live server to the POC server, port and set the ranks

                 

                UPDATE [dbo].[servgrp_board]

                SET serverName = 'POCServer1.mydomain.com'

                ,serverPort = 1000

                ,opFlags = '0;0;0;0;0;0;0;0;0;0;0;0;0;0;0'

                WHERE serverName = 'LiveServer1.mydomain.com'

                 

                Remove the other servers (old servers, DR servers, etc) if not in the server group

                 

                DELETE [servgrp_board]

                WHERE serverName IN ('OldServer2.mydomain.com','DRServer3.mydomain.com')

                 

                Clean out pending FTS items

                 

                TRUNCATE TABLE ft_pending

                 

                After doing all of this, we were able to do a clean upgrade.