1 Reply Latest reply on Mar 8, 2018 12:23 AM by Henrik Hauchwitz

    When the user take too long to submit an "operator dialog" it returns compensation

    Paulo Freire

      Hi experts,


      In a process that uses "operator dialog" object if the user takes too long to submit the dialog (fill a field or click on OK button) the process triggers compensation as below:


      An error occurred that triggered compensation:

        Summary: Execution failed.

        Detail: A timeout occurred waiting for user input.


      Does anyone know how to set a timeout or avoid this behavior?





      Paulo Freire



        • 1. Re: When the user take too long to submit an "operator dialog" it returns compensation
          Henrik Hauchwitz

          Hi Paulo,


          Can you specify after what period of time, compensation occurs?
          According to this documentation page, there are two global timeouts (idle and workflow execution)


          The workflow execution timeout seems to have a default value of 60 minutes. I'm guessing you experience the compensation earlier than this?
          If not, and compensation actually occurs somewhere after that amount of time, you might wan't to contact support for changing this value.
          At least, that is suggested in the comments on the documentation of an older BAO version (I think it was 7.6) for these parameters.


          While searching inside the OCP webapp directory, I found the workflow timeout parameter to be defined in the "web.xml" file.
          This file can be found under "CDP_INSTALLDIR/tomcat/webapps/baoocp/WEB-INF/web.xml" if you installed the OCP as part of CDP or under "OCP_INSTALLDIR/tomcat/webapps/baoocp/WEB-INF/web.xml" if you installed OCP seperately.


          Here's a warning though. These are the results of a very quick search by me. I've never worked with these parameters, as I've never experienced such issues. Thus I highly suggest you take these information with caution. Maybe someone else can either confirm or deny what I found out.


          My best guess though is, that you also contact support about this. Seems like some kind of global setting at leats.


          Best regards,