1 2 Previous Next 25 Replies Latest reply on Feb 8, 2018 1:54 AM by Ravindrakumar Rodge Go to original post
      • 15. Re: 9.1 Upgrade - Server fails to come up
        Andreas Mitterdorfer

        Thanks for clarification. I'm wondering on :
        NLS_CHARACTERSET
        UTF8

        as usually this is set as AL32UTF8. What was the NLS_LANG setting on your 8.1 box?

        • 16. Re: 9.1 Upgrade - Server fails to come up
          Jarl Groneng

          BMC changed  the password algorithm on v9. It seems that the installer did not complete the SHA256 conversion.

           

          How to set SHA256 algorithm for password from MD5

          • 17. Re: 9.1 Upgrade - Server fails to come up
            Ravindrakumar Rodge

            Can you try to point the AR to some other DB and see if that comes up (configuration in ar.cfg).

            This way you'll get clarity if this is problem with characterSet OR some metaData corruption.

             

            What was your observation after restarting the DB services? Have you tried that.

             

            Regards,

            Ravi

            • 18. Re: 9.1 Upgrade - Server fails to come up
              Satish K

              @Andreas Mitterdorfer -  From 8.1 host

               

              SQL> SELECT PARAMETER, VALUE FROM v$nls_parameters WHERE parameter LIKE '%CHARACTERSET';

               

              NLS_CHARACTERSET

              UTF8

               

              NLS_NCHAR_CHARACTERSET

              AL16UTF16

              • 19. Re: 9.1 Upgrade - Server fails to come up
                Satish K

                Interesting!!  Thanks for the pointer.

                Apologies, i might have mixed up with 8.1 DB while getting the table description and inferred the above conclusion.

                 

                Here is from 9.1 DB, looks like control table is updated properly.

                 

                SQL> select dbversion from control;

                        54

                 

                SQL> desc control;

                Name                                      Null?    Type

                ----------------------------------------- -------- ----------------------------

                DBVERSION                                 NOT NULL NUMBER(15)

                SCHEMAID                                  NOT NULL NUMBER(15)

                FILTERID                                  NOT NULL NUMBER(15)

                SERVERID                                  NOT NULL NUMBER(15)

                CONTAINERID                               NOT NULL NUMBER(15)

                ACTLINKID                                 NOT NULL NUMBER(15)

                ADMINEXTID                                NOT NULL NUMBER(15)

                CHARMENUID                                NOT NULL NUMBER(15)

                DBUPDATE                                           NUMBER(15)

                IMAGEID                                   NOT NULL NUMBER(15)

                RELGENSTATE                                        NUMBER(15)

                TASKID                                    NOT NULL NUMBER(15)

                INSTALLSTATE                              NOT NULL NUMBER(15)

                INSTALLHOST                                        VARCHAR2(66)

                ASSOCIATIONID                             NOT NULL NUMBER(15)

                DROPVERSION                               NOT NULL NUMBER(15)

                PREVDBVERSION                                      NUMBER(15)

                USESHA256                                          VARCHAR2(10)

                 

                SQL> SELECT dbVersion, actlinkId, adminExtId, associationId, containerId, filterId, schemaId, imageId, charMenuId, prevDbVersion, relGenState, taskId, useSHA256 FROM control;

                 

                        54       6749          1             1         316       7391       1230

                         5        750            31                      0 true

                • 20. Re: 9.1 Upgrade - Server fails to come up
                  Satish K

                  Since this the only host with 9.1 binaries & 9.1 DB, couldn't bring it up with any of the 8.1 DB hosts.

                  We haven't restarted the DB yet, will try that next.

                  • 21. Re: 9.1 Upgrade - Server fails to come up
                    Satish K

                    Also, I would assume opting for SHA256  (from ar.conf) is optional, since the server should be able to deal with existing 8.1 credentials.

                     

                    SQL> SELECT dbVersion, useSHA256 FROM control;

                            54    true

                     

                    I will give a try adding Use-SHA256: T to ar.conf and restart.

                    • 22. Re: 9.1 Upgrade - Server fails to come up
                      Satish K

                      Even after bouncing DB & adding "Use-SHA256: T" to ar.conf

                      Tue Feb 06 11:07:17.552 2018 Tue Feb 06 11:07:17.552 2018 Error initializing AR Server: ERROR (240): Message not in catalog; Message number = 240; @ : <1521>

                       

                      From SQL log, right before the error

                       

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5070 */ BEGIN TRANSACTION

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5080 */ COMMIT TRANSACTION

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5140 */ Generating prepared statement

                      <SQL > <TID: 0000000144> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5140 */ Generating prepared statement

                      <SQL > <TID: 0000000144> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ OK

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ OK

                      <SQL > <TID: 0000000144> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ Binding [2] parameters to prepared statement

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ Binding [0] parameters to prepared statement

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ OK

                      <SQL > <TID: 0000000144> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ OK

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ SELECT T1061.C1 FROM T1061 ORDER BY T1061.C1 ASC

                      <SQL > <TID: 0000000144> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5150 */ SELECT T1221.C1, T1221.C1436, T1221.C1434, T1221.C1435, T1221.C1439, T1221.C1437 FROM T1221 WHERE ((T1221.C3 >= 0) OR (T1221.C6 >= 0)) ORDER BY T1221.C1 ASC

                      <SQL > <TID: 0000000144> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5240 */ OK

                      <SQL > <TID: 0000000077> <RPC ID: 0000000000> <Queue: Init      > <Client-RPC: 10       > <USER: ARSERVER                                     > <Overlay-Group: 1         > /* Tue Feb 06 2018 11:07:17.5430 */ OK

                       

                      SQL> select schemaid, name from arschema where schemaid in ('1221', '1061');

                       

                            1061      AR System Current License Usage

                            1221      AR System Service Failover Whiteboard

                      • 23. Re: 9.1 Upgrade - Server fails to come up
                        Ravindrakumar Rodge

                        Based on some observations while working on some customers environment, I have observed that there happens to have some locking obtained over the schema or other db objects due to which server fails to come up. And restarting the db services helped in some scenarios.

                         

                        Let us know how that goes for you.

                         

                        Regards,

                        Ravi

                        • 24. Re: 9.1 Upgrade - Server fails to come up
                          Satish K

                          Thanks Ravi.  We did restart the DB for the previous attempt (the above post)  , we still ended up with same error.

                           

                          If we don't get any break through, I think we will have to got for another install attempt , but with 9.1.04

                          • 25. Re: 9.1 Upgrade - Server fails to come up
                            Ravindrakumar Rodge

                            Can you pull AR System Maintenance Tool -> zip all logs and post it here.

                             

                            Regards,

                            Ravi

                            1 2 Previous Next